Sondeo

Escritorios alternativos Linux

¿Cuál prefieres?

  •  Xfce
  •  LXDE
  •  Razor-qt
  •  Enlightenment 0.17

Resultados
Other polls | 4,137 voters | 2 comentarios
· Próximas fechas Curso Global de Servidores con CentOS 6.
· Taller de programación de Python.
· Curso de programación de PHP.
· Prueba ALDOS 1.4.5. Nuestro sistema operativo para escritorio.

Instalando CentOS 5 y tutorial Wifi Atheros.

Esta madrugada me quede instalando el reluciente CentOS 5 con varios problemas para ver si me detectaba mis tarjetas y controladores. Por suerte en un servidor que tengo por ahí, me detecto la tarjeta RAID SATA 3152 que todas estas semanas estaba sufriendo con el 4, uff que suerte sino tenia que usar Fedora (agghh) o bueno Ubuntu Server.

bueno continuando con mi amanecida: listo para instalar.. tenia 5 CD's, el 6to aun iba en 50 %. Así que me aventuré a instalarlo nomas, la desgracia era que, por más que eliminaba programas me pedía siempre los 6 discos para instalar. Buscando tener la MÍNIMA instalación (inclusive sin soporte de idiomas solo base) me pidió al fin 5 discos (ahora veo todo va a ser DVDiso). También resaltaría que en mi laptop me detectó el driver gráfico intel 915.

Todo ok instaló, pero como instalé mínimo me dio un init 3. texto. sin internet.

Bueno dije, probaré el yum MEDIA , para instalar con CDs a lo Debian. Pero al final no funciono me daba error siempre (igual que en el 4, solo me funciona con el X levantado :S ). Así que me bajé los 6 CD's a mi disco (ya termino el 6to de descargar) y lo hice depósito local

Por mala suerte siempre me pedía el media del CD, así me quede analizando los repodata y sus XML. y los comparé con mi CentOS 4.

Me dí la sorpresa que viene con un parámetro de etiqueta que fuerza instalar desde el CD en todos los XML.gz.

Pues me instalé createrepo.. y le di  en mi caso :

createrepo /var/ftp/CentOS/

Me creo los nuevo repodata ahora si funcionaban :)

Ahora opté por instalar el KDE. le di instalar yum a todo lo qe tenia KDE. me levanto pero sin fuentes... le seguí dando horas para instalar los paquetes. (no había yum groupinstall ... creo tenia que hacer un parámetro al hacer createrepo)

Suerte ya tenia KDE levantado. sin internet ni wireless detectado (igual que en el 4).
Pero si me detecto mi tarjeta gráfica con todas las resoluciones. :)

ahora pues el siguiente paso era que me detecte el wifi... revise y vi que esta igual que el 4 para el chip Atheros que tengo.

Asi que recuerdo usaba el repo extras de centos4 un paquete llamado madwifi.

Mi tutorial WIFI centOS Atheros madWIFI

Para mi desgracia veo en internet (ya habia levando mi kubuntu Live) que no hay RPM's , busco en internet y veo un tutorial compilando fuentes http://blog.tripthelight.net/?p=3 . Bueno,  habrá que hacerlo pa inaugurar el CentOS 5 me dije. Parecia todo facil

yum install gcc kernel-devel kernel-headers rpm-build

Además tambien me pidio otros paquetes que como siempre no aparecieron en el tutorial asi que (le dí para los que quieren wifi):

yum install unidef redhat-rpm-config

También me descargue las fuentes de madwifi  http://downloads.sourceforge.net/madwifi/madwifi-0.9.3.tar.bz2
y también el kernel RPM src  de aquí: http://mirror.centos.org/centos/5/updates/SRPMS/

Bueno ah continuar, seguí el manual hasta aquí:

mkdir /usr/src/redhat
rpm -ivh kernel-2.6.18-*.el5.src.rpm
cd /usr/src/redhat/SPECS
vi kernel-2.6.spec
rpmbuild -bb kernel-2.6.spec


ZZZZZZZZZZZZZZZZZZZzzzzzzzzz....

ls -al /lib/modules/2.6.18-8*.el5
cd /lib/modules/2.6.18-*.el5
rm build
ln -s /usr/src/redhat/BUILD/kernel-2.6.18/linux-2.6.18.* /lib/modules/2.6.18-8.*/build
cd /root
tar xjf madwifi-0.9.3.tar.bz2
cd madwifi-0.9.3
make


Hasta ahí todo bien , inclusive me funciono eso del rpmbuild... pero en el make no me funcionó. Pero ahora dije , mejor veo el error.. ví que me pedía un biblioteca utsre*.h que no aparecía en la ruta donde lo había precompilado.

Así que le lo busque y vi que estaba en la misma raiz del kernel fuente, le di asi :


export KERNELPATH=/usr/src/kernels/2.6.18-8.*
make
make install


Ahora si. Todo compilado (rápido el make como nunca :| ), ahora a cargar módulos:

modprobe ath_pci
lsmod | grep ath
vi /etc/modprobe.conf
alias ath0 ath_pci
alias wifi0 ath_pci
options ath_pci autocreate=sta


Luego:

vi /etc/sysconfig/wpa_supplicant

INTERFACES="-iath0"
DRIVERS="-Dmadwifi"


Hasta ahí terminaba el manual, faltaba ahora cargar la tarjeta de red. Me fui al menú KDE/Administracion/RED ... veo que me aparece detectado Atheros y ath_pci

Le doy la típica del asistente de configuración. selecciono mi Atheros hardware... y como nunca abrir el KwifiManager y me salio una barra verde-

Todo ok.. funcionando.


Otras cosas mas que agregar es que ya hay repo de DAG para centOS 5 :)   y solo HAY paquetes en el repo update (no hay ni un paquete en plus, addons, etc). :S

Salu2 y estaré probando mi tutorial de sambaLDAP y otras cosas a ver si corren.

.

Atención: Salvo que se indique lo contrario, la licencia del texto de este documento es Creative Commons Reconocimiento 2.5, mediante la cual usted tiene permitido copiar, modificar, comunicar y distribuir el contenido de este texto, de manera total o parcial, y publicarlo o difundirlo en cualquier otro sitio de Internet o medio de comunicaciòn, siempre y cuando incluya o cite (1)el nombre de este sitio de Internet, (2)enlace permanente de este documento, (3)nombre del autor y (4)la misma licencia de distribución.

Opciones: Imprimir | Recomendar | Enlace permanente

Twitter Facebook Google Bookmarks Bitacoras.com Wikio Menéame Technorati Bloglines Digg Yahoo Buzz
 
Seguimientos (Trackback)
URL de seguimiento para esta entrada: http://www.alcancelibre.org/trackback.php/20070415143344897
Sin comentarios de seguimientos para esta entrada.
 
Instalando CentOS 5 y tutorial Wifi Atheros. | 1 comentarios | Crea cuenta nueva
Los siguientes comentarios son de la persona que los haya enviado. Este sitio se deslinda de cualquier responsabilidad respecto de las opiniones expresadas por los participantes en nuestros foros y secciones de comentarios, y el hecho de publicar las mismas no significa que se esté de acuerdo con éstas.
Instalando CentOS 5 y tutorial Wifi Atheros.
Escrito por: David Rios el 16/04/2007, 13:50
: (|)

ya me las olia.... y para mayor comodidad me baje el iso en DVD
instale CentOS 5 con repositorio local sin ningun problema.... (createrepo rulez)
el yum media = :S

le instale gnome para recibir listo al-desktop y al-server  @_@V  y asi quedo:

http://img128.imageshack.us/img128/7956/pantallazoxv0.png
[ # ]