¿Actualizaste a PHP 5.6 o 7.0.x y dejaron de funcionar tus Webmails?

Uno de los cambios más importates en PHP 5.6 y versiones posteriores es que de modo predeterminado ahora se validan los certificados de las conexiones SSL/TLS. Lamentablemente significa malas noticias para quienes utilizan certificados auto-firmados en servidoes de correo y utilizan SSL/TLS para las conexiones hacia el servicio de IMAP/SMTP. Hay una solución sencilla.

Si utilizas RoundCube Mail, edita el archivo config.inc.php.

Si utilizar Group-Office, edita el archivo config.php.

Añade el siguiente contenido al final del archivo correspondiente:

$config['imap_conn_options'] = array(
  'ssl'                      => array(
     'allow_self_signed'     => true,
     'verify_peer'           => false,
     'verify_peer_name'      => false,
   ),
 );
$config['smtp_conn_options'] = array(
  'ssl'                      => array(
     'allow_self_signed'     => true,
     'verify_peer'           => false,
     'verify_peer_name'      => false,
   ),
 );

Si utilizas SquirelMail, me temo que hay malas noticias. Hasta ahora no hay forma de hacer que funcione correctamente y habrña que esperar el lanzamiento de la versión 1.4.23 o 1.5.x. Sólo es posible utilizarlo instalado en el mismo anfitrión local (localhost) sin realizar conexiones SSL/TLS hacia IMAP/SMTP o bien utilizando SSL/TLS pero con PHP 5.5.

Comentarios (0)


Alcance Libre
http://www.alcancelibre.org/article.php/20160605021306260