Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

Corrección de problema de spamassassin «error: Argument perl_version isn't numeric in numeric ge (>=)»

Recientes actualizaciones de CentOS 6 y 7 y Red Hat Enterprise Linux 6 y 7 han ocasionado problemas para la ejecución de sa-learn y otros componentes de SpamAssassin. A continuación la solución al problema.

El problema consiste en la incapacidad de SpamAssassin para determinar la versión de Perl en el sistema. Ésto ocasiona que varios componentes sean incapaces de funcionar correctamente.

Procedimiento.

Cambie a root:

su -l

Instale la herramienta patch

yum -y install patch

Cambiarse a /tmp pàra realizar descarga de parches.

cd /tmp

Descargue los parches de SpamAssassin:

wget "http://svn.apache.org/viewvc/spamassassin/trunk/lib/Mail/SpamAssassin/Conf.pm?r1=1642207&r2=1642206&pathrev=1642207&view=patch" -O conf.pm.patch
wget "http://svn.apache.org/viewvc/spamassassin/trunk/lib/Mail/SpamAssassin/Conf/Parser.pm?r1=1642207&r2=1642206&pathrev=1642207&view=patch" -O parser.pm.patch

Respalde archivos a modificar de la instalación original de SpamAssassin:

cp -p /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm{,.orig}
cp -p /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm{,.orig}

Aplique los parches correctivos a SpàmAssassin:

patch /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm < conf.pm.patch
patch /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm < parser.pm.patch

Ejecute lo siguiente para reiniciar el servicio spamassassin:

service spamassassin restart

Fuente: [SOLVED] [Solved] spamassassin error: Argument perl_version isn't numeric in numeric ge (>=)


Atención: Salvo que se indique lo contrario, la licencia del texto de este documento es Creative Commons Reconocimiento 2.5, mediante la cual usted tiene permitido copiar, modificar, comunicar y distribuir el contenido de este texto, de manera total o parcial, y publicarlo o difundirlo en cualquier otro sitio de Internet o medio de comunicaciòn, siempre y cuando incluya o cite (1)el nombre de este sitio de Internet, (2)enlace permanente de este documento, (3)nombre del autor y (4)la misma licencia de distribución.

Opciones: Imprimir | Recomendar | Enlace permanente

Twitter Facebook Google Bookmarks Bitacoras.com Wikio Menéame Technorati Bloglines Digg Yahoo Buzz

Seguimientos (Trackback)

URL de seguimiento para esta entrada:
http://www.alcancelibre.org/trackback.php/correccion-spamassassin-20141201
  • Corrección de problema de spamassassin «error: Argument perl_version isn't numeric in numeric ge (>=)»
  • 0comentarios
  • Crea cuenta nueva
Agregar comentario

Los siguientes comentarios son de la persona que los haya enviado. Este sitio se deslinda de cualquier responsabilidad respecto de las opiniones expresadas por los participantes en nuestros foros y secciones de comentarios, y el hecho de publicar las mismas no significa que se esté de acuerdo con éstas.