Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

El desastre del controlador Poulsbo para tarjetas gráficas deja caer sobra de incertidumbre sobre Moblin.

El proyecto Moblin inició en 2007 con el objetivo de crear una plataforma basada sobre GNU/Linux para dispositivos móviles pequeños. Aunque la tecnología que utiliza es interesante y exhibe considerable potencial, el sorprendente grado de ambivalencia de Intel sobre problemas fundamentales como la compatibilidad de dispositivos y controladores de código fuente abierto podrían amenazar la relevancia de Moblin. (Nota para resumir: usuarios de GNU/Linux, eviten comprar ultra-portátiles basadas sobre GMA500.)

Uno de los más claros ejemplos es la declinación al compromiso de Intel en ko relacionado a los controladores para Linux para sus tarjetas gráficas integradas GMA500. Este circuito integrado que también es conocido como Poulsbo, se incluye en muchas ultra-portátiles (netbooks) como modelos recientes de Acer Aspire One y ciertos modelos de Dell Mini. A diferencia de otra soluciones gráficas integradas de Intel, Poulsbo está parcialmente basado sobre PowerVR de Imagination Technologíes y solo está soportado en Linux de manera marginal. Los controladores para Poulsbo son un completo desastre y resulta casi imposible para las distribuciones de GNU/Linux el poder incluir soporte.

Las partes de código fuente abierto de Poulsbo, que actualmente están en la sección de código descartado enel árbol Git, llevan tiempo sin mantenimiento y sin recibir mejoras desde marzo de 2008. Este código funciona a medias con versiones recientes del núcleo de Linux. Los controladores también requieren binarios privativos, los cuales aparentemente son imposibles de distribuir libremente, para poder gestionar cosas como la aceleración 3D. Para más detalles respecto de que tanestropeados están estos controladores, solo hay que leer la publicación de Adam Williamson, ingeniero de aseguramiento de calidad de Red Hat, que básicamente describe de manera precisa y fácil de entender respecto de que tan mal están las cosas con Poulsbo.

El verdadero problema, sin embargo, es la falta de respuesta de Intel hacia las preocupaciones expresadas por la comunidad Linux. Intel ha respondido a las críticas con evasivas extraordinarias y ha fallado en proporcionar una aclaración significativa de los hechos en relación a la extensión que tiene la intención de proveer de soporte para programas Linux para los circuitos integrados que vende a los distribuidores.

A algunas críticas por la falta de soporte para GMA500, Intel ha respondido que ha sido culpa de los usuarios de GNU/Linux por comprar equipos con este circuito integrado y que los controladores de código fuente abierto en el mercado de dispositivos móviles son innecesarios porque los productos de este mercado se diseñan para que solo puedan ser actualizados por un operador de servicio o distribuidor.

En resumen, Intel reconoce el problema de GMA500 y sus controladores para GNU/Linux, pero se niega a hacerse responsable. La luz al final del túnel es que la Fundación Linux ha mencionado brevemente que tiene información respecto de que parece en un futuro habrá un controlador de código fuente cerrado para Poulsbo y que estará basado sobre Gallium3D y que podrían ser incluidos en Moblin 2.2 el próximo año.

Entre tanto, la mejor recomendación para usuarios de GNU/Linux es evitar adquirir ultra-portátiles basadas sobre el circuito integrado GMA500.

Fuente: Ars Technica.


Atención: Salvo que se indique lo contrario, la licencia del texto de este documento es Creative Commons Reconocimiento 2.5, mediante la cual usted tiene permitido copiar, modificar, comunicar y distribuir el contenido de este texto, de manera total o parcial, y publicarlo o difundirlo en cualquier otro sitio de Internet o medio de comunicaciòn, siempre y cuando incluya o cite (1)el nombre de este sitio de Internet, (2)enlace permanente de este documento, (3)nombre del autor y (4)la misma licencia de distribución.

Opciones: Imprimir | Recomendar | Enlace permanente

Twitter Facebook Google Bookmarks Bitacoras.com Wikio Menéame Technorati Bloglines Digg Yahoo Buzz

Seguimientos (Trackback)

URL de seguimiento para esta entrada:
http://www.alcancelibre.org/trackback.php/desastre-poulsbo-siembra-incertidumbre-m
  • El desastre del controlador Poulsbo para tarjetas gráficas deja caer sobra de incertidumbre sobre Moblin.
  • 1comentarios
  • Crea cuenta nueva
Agregar comentario

Los siguientes comentarios son de la persona que los haya enviado. Este sitio se deslinda de cualquier responsabilidad respecto de las opiniones expresadas por los participantes en nuestros foros y secciones de comentarios, y el hecho de publicar las mismas no significa que se esté de acuerdo con éstas.

  • El desastre del controlador Poulsbo para tarjetas gráficas deja caer sobra de incertidumbre sobre Moblin.
  • Escrito por:Anonymous el  10/05/2010, 16:54

Yo soy una de estas víctimas. Me compro un fabuloso Asus Eee 1201HA y me encuentro con este problema.

Es vergonzoso lo que hacen algunos fabricantes de hardware. Se niegan a sabiendas que tarde o temprano será la Comunidad de desarrollo de software libre la que realizará el trabajo. De esta manera se ahorran mucho dinero en hacer unos drivers.

El estado actual (mayo de 2010) la cosa está bastante parada para Ubuntu 10.4 aunque sí hay un soporte para 9.10 que no he conseguido poner a punto. Por lo que estoy leyendo se está trabajando en ello, sobre todo porque muchos netbooks modernos funcionan con este chipset.

Miraros wiki.ubuntu.com/HardwareSupportComponentsVideoCardsPoulsbo#lucid