Soporte para PHP4 será descontinuado en Geeklog.

A partir de la versión 1.8.0 de Geeklog, se requerirá PHP 5.2.0 o versiones posteriores. La última versión de Geeklog que permitirá utilizar PHP4 será la 1.7.2, la cual será publicada durante los primeros meses de 2011.

Para poner las cosas en perspectiva: El soporte de PHP4 provisto por el equipo de desarrollo de PHP oficialmente terminó el 31 de diciembre de 2007. Un último lanzamiento oficial, PHP 4.4.9, fue realizado el 8 de agosto de 2008. Desde entonces se han dejado de publicar parches de seguridad y correcciones para PHP4.

Algunas distribuciones de GNU/Linux con soporte de largo plazo, Red Hat Enterprise Linux 4 (RHEL4) y CentOS 4 entre las más notables, se distribuyeron con PHP4 al momento de su lanzamiento y por tanto se comprometieron a continuar el soporte de PHP4 hasta el final del ciclo de vida de estas versiones. Por tanto, desafortunadamente (para algunos), aún existen instalaciones de PHP4 con soporte y en producción.

Como un compromiso y a fin de continuar brindando servicio a aquellos usuarios que estén atrapados con una instalación de este tipo, el equipo de Geeklog continuará proveyendo parches de seguridad para la rama de Geeklog 1.7 «cuando sea posible» hasta el 29 de febrero de 2012 (fecha que coincide con el fin de la fase 3 de producción para RHEL4). Con «cuando sea posible» significa que los parches de seguridad se publicarán tan pronto como sea posible, pero sin que signifique que se publiquen el mismo día que para el lanzamientomás reciente. Mientras más avanzadas las versiones, se requiere más trabajo para adecuar las correcciones en versiones más antiguas.

Cabe señalar que los desarrolladores de Geeklog sugieren cambiar o migrar hacia servidores que utilicen PHP 5.2 en adelante tan pronto como sea posible.

Una aclaración respecto de PHP 4.3: Geeklog 1.7.x requiere PHP 4.4.0 para poder realizar la instalación. Este requerimiento, sin embargo, solo es debido a los paquetes de PEAR que se distribuyen junto con estas versiones de Geeklog, sin que realmente lo requiera Geeklog en si. Por tanto, si se quiere utilizar Geeklog 1.7.x en servidores con PHP 4.3, se puede hacer lo siguiente:

 

Próximos lanzamiento de Geeklog.

Geeklog 1.7.2 será publicado durante algún momento del primer trimestre de 2011. Será un lanzamiento correctivo, enfocado en resolver un problema de compatibilidad con PHP4 y que será la base para poder continuar el soporte mencionado arriba para PHP4 hasta 2012.

Geeklog 1.8.0 se agendó originalmente para ser lanzado en noviembre pasado. Obviamente fue imposible cumplir con esa fecha y es por tal motivo que el lanzamiento se ha vuelto a agendar para abril de 2011. Como se mencionó arriba, esta versión carecerá de soporte para PHP4.

Fuente de información: Geeklog.

Comentarios (0)


Alcance Libre
http://www.alcancelibre.org/article.php/soporte-php4-descontinuado-geeklog