Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Redes y Servidores Nuevo tema Publicar Respuesta
 Violación de segmento en centOS
Tema anterior Tema siguiente
   
andrea69|
Publicado en 25/11/16 06:41 (Leído 580 veces)  

Nuevo

Estado: desconectado
Forum User

Inscrito: 25/11/16
Publicaciones: 6
Hola que tal.
Me encuentro trabajando con nodejs - npm en un servidor local centOS pero al trabajar con el npm me sale una violacion de segmento por ejemplo si meto esto comandos npm cache clean -f o si quiero saber una version npm -version me sale violacion de segmento. y al querer iniciar un etherpad que tengo ahi me sale lo mismo violacion de segmento npm.

ojala puedan ayudarme.

Saludos cordiales.
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 25/11/16 08:42  

Admin

Estado: desconectado
Site Admin

Inscrito: 17/02/07
Publicaciones: 1580
País:Mexico
¿Compilaste desde fuentes o utilizaste paquetería de EPEL o Fedora? ¿Qué versión de nodejs estás utilizando? El error que reportas es típico de utilizar paquetería de Fedora en CentOS en lugar de paquetería compilada específicamente para CentOS.
 
Perfil Sitio Web
 Citar
andrea69|
Publicado en 26/11/16 03:44  

Nuevo

Estado: desconectado
Forum User

Inscrito: 25/11/16
Publicaciones: 6
la version nodejs que tengo v0.10.46 instale mediante yum -y install nodejs y yum -y install npm
 
Perfil
 Citar
andrea69|
Publicado en 26/11/16 03:46  

Nuevo

Estado: desconectado
Forum User

Inscrito: 25/11/16
Publicaciones: 6
Citando a: Joel Barrios Dueñas

¿Compilaste desde fuentes o utilizaste paquetería de EPEL o Fedora? ¿Qué versión de nodejs estás utilizando? El error que reportas es típico de utilizar paquetería de Fedora en CentOS en lugar de paquetería compilada específicamente para CentOS.




la version nodejs que tengo v0.10.46 instale mediante yum -y install nodejs y yum -y install npm
sigo sin encontrar la solucion como debo compilar los archivos ? cabe mencionar que este error se presento actualmente antes funcionaba corectamente.
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 26/11/16 09:46  

Admin

Estado: desconectado
Site Admin

Inscrito: 17/02/07
Publicaciones: 1580
País:Mexico
CentOS no incluye ni nodejs ni npm en ninguno de sus almacenes YUM oficiales. Sólo está disponible en almacenes YUM de terceros (EPEL, NodeSource, etc.). ¿De cuál almacén yum lo instalaste? Para instalarlos tuviste que haber puesto un archivo de configuración dentro de /etc/yum.repos.d/ o ejecutar un script de nodesource.com.

¿Qué versión de CentOS estás utilizando?

¿La paquetería que utilizaste es para esa misma versión de CentOS?

Ejecuta lo siguiente para conocer el origen de la paquetería:

PHP Formatted Code
yum info nodejs npm


Y publica la salida de lo anterior.

Si instalaste la paquetería desde los almacenes YUM de https://nodejs.org/en/download/package-manager/#enterprise-linux-and-fedora, me temo que lo mejor que puedes hacer es solicitar el soporte en https://github.com/nodesource/distributions/issues/.
 
Perfil Sitio Web
 Citar
andrea69|
Publicado en 27/11/16 10:24  

Nuevo

Estado: desconectado
Forum User

Inscrito: 25/11/16
Publicaciones: 6
yum info nodejs npm <---- el resultado del comando fue este
Complementos cargados:fastestmirror
Loading mirror speeds from cached hostfile
epel/metalink | 9.0 kB 00:00
* base: centos.mirror.vexxhost.com
* epel: mirror.steadfast.net
* extras: centos.mirror.vexxhost.com
* updates: centos.mirror.vexxhost.com
* webtatic: us-east.repo.webtatic.com
base | 3.7 kB 00:00
extras | 3.3 kB 00:00
nodesource | 2.5 kB 00:00
pgdg94 | 4.1 kB 00:00
updates | 3.4 kB 00:00
webtatic | 3.6 kB 00:00
zeroc-ice | 1.2 kB 00:00
Paquetes instalados
Nombre : nodejs
Arquitectura : i686
Versión : 0.10.46
Lanzamiento : 1nodesource.el6
Tamaño : 19 M
Repositorio : installed
Desde el repositorio : nodesource
Resumen : JavaScript runtime
URL : http://nodejs.org
Licencia : MIT and ASL 2.0 and ISC and BSD
Descripción :Node.js is a platform built on Chrome\'s JavaScript runtime
: for easily building fast, scalable network applications.
: Node.js uses an event-driven, non-blocking I/O model that
: makes it lightweight and efficient, perfect for data-intensive
: real-time applications that run across distributed devices.

Paquetes disponibles
Nombre : npm
Arquitectura : noarch
Versión : 1.3.6
Lanzamiento : 5.el6
Tamaño : 329 k
Repositorio : epel
Resumen : Node.js Package Manager
URL : http://npmjs.org/
Licencia : Artistic 2.0
Descripción :npm is a package manager for node.js. You can use it to install and publish your
: node programs. It manages dependencies and does other cool stuff.


Que puedo hacer en este aun sigo sin encontrar solucion a este problema.... trate compilar con make un version del nodejs pero se me romper las compilaciones este es 1 de los paquetes que trate de compilar y se compen...

/bin/sh: línea 1: 18793 Violación de segmento "/root/node-v0.8.18/out/Release/mksnapshot" --log-snapshot-positions --logfile "/root/node-v0.8.18/out/Release/obj.target/v8_snapshot/geni/snapshot.log" "/root/node-v0.8.18/out/Release/obj.target/v8_snapshot/geni/snapshot.cc"
make[1]: *** [/root/node-v0.8.18/out/Release/obj.target/v8_snapshot/geni/snapshot.cc] Error 139
make[1]: se sale del directorio `/root/node-v0.8.18/out'
make: *** [node] Error

 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 28/11/16 11:41  

Admin

Estado: desconectado
Site Admin

Inscrito: 17/02/07
Publicaciones: 1580
País:Mexico
Me temo que tu problema sólo podrás resolverlo en la página de soporte de nodesource, porque evidentemente se trata de un problema específico de dichos paquetes y no de CentOS en si.

https://github.com/nodesource/distributions/issues/

Si aún te es posible, utiliza CentOS 7 en lugar de CentOS 6. Probablemente tengas menos problemas utilizando CentOS 7.
 
Perfil Sitio Web
 Citar
andrea69|
Publicado en 29/11/16 07:38  

Nuevo

Estado: desconectado
Forum User

Inscrito: 25/11/16
Publicaciones: 6
Le agradesco por su ayuda utilizare escribire utilizare pagina aun sigo teniendo este problema no he tenido exito. Espero pronto poder escribir que ya se pudo resolver.

Gracias.
saludos.




 
Perfil
 Citar
Contenido generado en: 0,21 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 02:01 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado