Cursos Servidores con Centos 6
Sistema Operativo ALDOS
MongoDB Banner
Curso PHP
Dezoft

Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Redes y Servidores Nuevo tema Publicar Respuesta
 Servidor DNS esclavo no responde
Tema anterior Tema siguiente
   
al-serv
Publicado en 21/02/18 01:50 (Leído 801 veces)  

Miembro Activo
Forum User

Inscrito: 01/03/08 Publicaciones: 622
País:Cataluña
buenas!
estoy creando un servidor esclavo de DNS, en el master he permitido que pueda trasmitir al esclavo y así lo hace correctamente e internamente si pongo la ip en mis dns del equipo, la ip del esclavo, funciona bien
el problema es cuando desde el exterior hago un test y me pone que no se puede conectar

tengo iptables con INPUT abierto TCP y UDP del 53

el Router esta con DMZ hacia mi servidor esclavo...

Por donde empiezo a mirar?

Tengo publicado los dos NS en mi registrador de nombre correctamente

 
Perfil Sitio Web
 Citar
al-serv
Publicado en 21/02/18 03:22  

Miembro Activo
Forum User

Inscrito: 01/03/08 Publicaciones: 622
País:Cataluña
he hecho un test y veo que el 53 udp no esta abierto.. en el iptables lo tengo input 53 udp accept... en el router un DMZ y también desviado manualmente este puerto.... que puedo mirar más? ya que tendría que ser el servicio quien abra ese puerto no?
 
Perfil Sitio Web
 Citar
Joel Barrios Dueñas
Publicado en 21/02/18 09:10  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1653
País:Mexico
Tanto maestro como esclavo deben tener abierto el puerto 53 por tcp y udp.

Por favor, publica un extracto de la la sección 'options' de configuración de /etc/named.conf de ambos servidores.

De ser posible, también una copia de la configuración de cortafuegos de ambos.
 
Perfil Sitio Web
 Citar
Joel Barrios Dueñas
Publicado en 22/02/18 05:45  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1653
País:Mexico
Si tienes SELinux activo, debes usar 'setsebool -P named_write_master_zones=1'.
 
Perfil Sitio Web
 Citar
al-serv
Publicado en 22/02/18 05:56  

Miembro Activo
Forum User

Inscrito: 01/03/08 Publicaciones: 622
País:Cataluña
el selinux lo tengo deshabilitado en los 2 mientras hago pruebas
en el esclavo conecta, en los dos servidores llego al UDP desde el exterior.

El fichero named.conf:

options {
listen-on port 53 { any; };
listen-on-v6 port 53 { any; };
allow-query {
any;
};
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
memstatistics-file "/var/named/data/named_mem_stats.txt";
version " ";
allow-recursion { trusted-servers; };
allow-query-cache { trusted-servers; };

dnssec-enable yes;
dnssec-validation yes;
dnssec-lookaside auto;

/* Path to ISC DLV key */
bindkeys-file "/etc/named.iscdlv.key";
forwarders {
8.8.8.8;
8.8.4.4;
};
allow-transfer {
trusted-servers;
};
};
 
Perfil Sitio Web
 Citar
al-serv
Publicado en 07/03/18 09:52  

Miembro Activo
Forum User

Inscrito: 01/03/08 Publicaciones: 622
País:Cataluña
No he averiguado el problema pero he levantado otro servidor esclavo en una ADSL de una compañia distinta y funciona, algo tiene la compañía que utilizo en el servidor principal que no deja que funcione un servidor DNS
Joel mil gracias por todo tu asesoramiento!
 
Perfil Sitio Web
 Citar
Contenido generado en: 0,12 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 10:07 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado