Cursos Servidores con Centos 6
Sistema Operativo ALDOS
MongoDB Banner
Curso PHP
Dezoft

Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Soporte técnico de ALDOS Nuevo tema Publicar Respuesta
 Problema para ingresar a ALDOS
Tema anterior
   
Nahui Ollin
Publicado en 02/02/19 05:45 (Leído 141 veces)  

Nuevo
confused
Forum User

Inscrito: 01/02/19 Publicaciones: 2
Hola, buenas noches.

Ayer instalé en mi computadora la versión más reciente de ALDOS con la /home cifrada , después instalé Peppermint 9.
Enseguida reinicie la computadora para ingresar a ALDOS para que se actualizara el sistema recién instalado, una vez hecho esto apago
la computadora.

El día de hoy cuando quiero empezar a utilizar ALDOS, resulta que después de que pasa el fondo gris con el logotipo de ALDOS, en lugar
de que aparezca la ventanita pidiendo que ingrese la contraseña de la /home, aparece en blanco sobre fondo negro lo siguiente:



[ 2.462736] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[ 2.462777] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
Introduzca la frase contraseña de /dev/sda5: [ingreso la contraseña pero enseguida aparece:]
No hay ninguna clave disponible con esa frase contraseña.



Y entonces no puedo entrar al sistema operativo ALDOS y no tengo idea de qué hacer para solucionar ese problema.
No es posible que no haya ninguna clave disponible con esa frase contraseña puesto que ya había podido entrar sin problemas
en una ocasión y tampoco es posible que me este equivocando de contraseña pues con esa contraseña, desde Peppermint 9, puedo
acceder a esa partición cifrada.

Las características de mi computadora son las siguientes:

Procesador Intel (R) Pentium (R)
RAM 2048 MB
Disco duro 500GB

Gracias por su atención. Hasta pronto.



 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 04/02/19 04:19  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1716
País:Mexico
¿Instalaste 1.4.14-20181227 o ALDOS-1.4.14-20180721? La edición ALDOS-1.4.14-20180721 tiene un bug con la gestión de /etc/mtab que corrige la versión 1.4.14-20181227.

¿Instalaste grub en el MBR del disco duro o en una partición? La versión de grub (0.97) que utiliza ALDOS-1.4.14 requiere que la partición para iniciar (boot) esté antes del cilindro 1024 (puedes migrar a grub2 si es necesario).

Sí instalaste ALDOS-1.4.14-20181227, inicia desde el LiveCD, abre una terminal y cambiate a root:

BASH Formatted Code
su -l


Valida sea correcta la frase contraseña del /home cifrado haciendo el procedimiento manual (cambia /dev/mapper/dispositivo por el dispositivo que corresponde a la partición cifrada):

BASH Formatted Code
cryptsetup luksOpen /dev/mapper/dispositivo nombre


Lo anterior te debe dar un dialogo en la terminal solicitando la frase contraseña. Si lo anterior funciona, crea un punto de montaje temporal y monta el dispositivo, igualmente para validar:

BASH Formatted Code
mkdir /mnt/temporal
mount /dev/mapper/nombre /mnt/temporal


Todo lo anterior es sólo para validar.

Determina qué particiones corresponden a /boot y / de ALDOS y monta éstas en punto de montaje temporal.

BASH Formatted Code
mkdir /mnt/temporal-boot
mkdir /mnt/temporal-root
mount /dev/sda1 /mnt/temporal-root
mount /dev/mapper/vg_algo-lv_root /mnt/temporal-root


Busca el archivo grub.conf dentro de la partición correspondiente a /boot y valida que la línea que corresponde a los argumentos de inicio del núcleo del sistema (kernel) incluya como argumento rd_LUKS_UUID=luks-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx o bien rd.luks.uuid=luks-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx . Ejemplo:

BASH Formatted Code
title ALDOS Linux (4.14.96-30.fc14.al.x86_64) 1.4.14 (Librepensador)
        root (hd0,0)
        kernel /vmlinuz-4.14.96-30.fc14.al.x86_64 ro root=/dev/mapper/vg_algo-lv_root rd_LVM_LV=vg_algo/lv_root rd_LUKS_UUID=luks-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx LANG=es_MX.UTF-8 KEYBOARDTYPE=pc KEYTABLE=es rhgb quiet
        initrd /initramfs-4.14.96-30.fc14.al.x86_64.i
mg

Localiza el archivo /etc/crypttab de la partición correspondiente a / y valida incluya algo similar a lo siguiente:

BASH Formatted Code
luks-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx  UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx  none


Puedes validar los valores de UUUID ejecutando blkid sin argumentos o bien utilizando una partición como argumento. Ejemplo:

BASH Formatted Code
blkid /dev/sda3

 
Perfil Sitio Web
 Citar
Nahui Ollin
Publicado en 06/02/19 02:49  

Nuevo
Forum User

Inscrito: 01/02/19 Publicaciones: 2
Instalé ALDOS-1.4.14-20181227 y el grub lo instalé en MBR

Y analizando tu respuesta me surge una duda:

¿crees que lo me has dicho pueda funcionar dado que mi tabla de particiones es la siguiente? :



y en la información de la partición /sda3 donde esta el boot dice Primer sector: 2048
con lo que supongo que está después del cilindro 1024.

Yo supongo que por todo lo anterior, todo lo que has me dijiste no me va a funcionar, pero realmente no lo sé.
Por otro lado, si el grub lo instalé en MBR ¿por qué esa etiqueta de boot me aparece en /sda3? , pues se
supone que si está en MBR, el boot debería de estar en /sda0.
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 14/02/19 04:52  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1716
País:Mexico
Teóricamente no debería darte problemas. Intenta hacer las validaciones que te sugiero arriba.
 
Perfil Sitio Web
 Citar
Contenido generado en: 0,15 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 02:34 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado