Cursos Servidores con Centos 6
Sistema Operativo ALDOS
Dezoft

Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Redes y Servidores Nuevo tema Publicar Respuesta
 ldap_bind: Invalid credentials (49)
Tema anterior Tema siguiente
   
Milt0n
Publicado en 09/01/08 12:13 (Leído 37095 veces)  

Nuevo
Forum User

Inscrito: 08/01/08 Publicaciones: 12
Hola a todos, siguiendo el manual "Cómo configurar OpenLDAP como servidor de autenticación." lo que quiero es conseguir una especie de active directory, pero en el momento de introducir este comando ldapadd -x -w -D 'cn=Administrador, dc=RED, dc=com' -h 127.0.0.1 -f base.ldif Enter LDAP Passwd: ldap_bind: Invalid credentials (49) me aparece ese error,¿que puedo hacer?
 
Perfil
 Citar
Milt0n
Publicado en 10/01/08 10:00  

Nuevo
Forum User

Inscrito: 08/01/08 Publicaciones: 12
Alguien puede ayudarme por favor mi archivo de configuracion es este



#
# See slapd.conf(5) for details on configuration options.
# This file should NOT be world readable.
#
include /etc/openldap/schema/core.schema
include /etc/openldap/schema/cosine.schema
include /etc/openldap/schema/inetorgperson.schema
include /etc/openldap/schema/nis.schema

# Allow LDAPv2 client connections. This is NOT the default.
allow bind_v2

# Do not enable referrals until AFTER you have a working directory
# service AND an understanding of referrals.
#referral ldap://root.openldap.org

pidfile /var/run/openldap/slapd.pid
argsfile /var/run/openldap/slapd.args

# Load dynamic backend modules:
# modulepath /usr/lib/openldap
# moduleload back_bdb.la
# moduleload back_ldap.la
# moduleload back_ldbm.la
# moduleload back_passwd.la
# moduleload back_shell.la

# The next three lines allow use of TLS for encrypting connections using a
# dummy test certificate which you can generate by changing to
# /etc/pki/tls/certs, running "make slapd.pem", and fixing permissions on
# slapd.pem so that the ldap user or group can read it. Your client software
# may balk at self-signed certificates, however.
# TLSCACertificateFile /etc/pki/tls/certs/ca-bundle.crt
# TLSCertificateFile /etc/pki/tls/certs/slapd.pem
# TLSCertificateKeyFile /etc/pki/tls/certs/slapd.pem

# Sample security restrictions
# Require integrity protection (prevent hijacking)
# Require 112-bit (3DES or better) encryption for updates
# Require 63-bit encryption for simple bind
# security ssf=1 update_ssf=112 simple_bind=64

# Sample access control policy:
# Root DSE: allow anyone to read it
# Subschema (sub)entry DSE: allow anyone to read it
# Other DSEs:
# Allow self write access
# Allow authenticated users read access
# Allow anonymous users to authenticate
# Directives needed to implement policy:
# access to dn.base="" by * read
# access to dn.base="cn=Subschema" by * read
# access to *
# by self write
# by users read
# by anonymous auth
#
# if no access controls are present, the default policy
# allows anyone and everyone to read anything but restricts
# updates to rootdn. (e.g., "access to * by * read"Guiño
#
# rootdn can always read and write EVERYTHING!

#######################################################################
# ldbm and/or bdb database definitions
#######################################################################

database bdb
suffix "dc=red,dc=com"
rootdn "cn=Administrador,dc=red,dc=com"
# Cleartext passwords, especially for the rootdn, should
# be avoided. See slappasswd(8) and slapd.conf(5) for details.
# Use of strong authentication encouraged.
# rootpw secret
# rootpw {crypt}ijFYNcSNctBYg
rootpw {SSHA}Aqui tengo la contraseña encriptada
directory /var/lib/ldap/autenticar


# The database directory MUST exist prior to running slapd AND
# should only be accessible by the slapd and slap tools.
# Mode 700 recommended.
directory /var/lib/ldap

# Indices to maintain for this database
index objectClass eq,pres
index ou,cn,mail,surname,givenname eq,pres,sub
index uidNumber,gidNumber,loginShell eq,pres
index uid,memberUid eq,pres,sub
index nisMapName,nisMapEntry eq,pres,sub

# Replicas of this database
#replogfile /var/lib/ldap/openldap-master-replog
#replica host=ldap-1.example.com:389 starttls=critical
# bindmethod=sasl saslmech=GSSAPI
# authcId=host/ldap-master.example.com@EXAMPLE.COM
 
Perfil
 Citar
Jaime M. Tan Nozawa
Publicado en 10/01/08 02:29  

Miembro regular
Forum User

Inscrito: 31/03/07 Publicaciones: 114
País:Peru
Quote by: Milt0n

Hola a todos, siguiendo el manual "Cómo configurar OpenLDAP como servidor de autenticación."


lo que quiero es conseguir una especie de active directory, pero en el momento de introducir este comando
ldapadd -x -w -D 'cn=Administrador, dc=RED, dc=com' -h 127.0.0.1 -f base.ldif
Enter LDAP Passwd:
ldap_bind: Invalid credentials (49)


me aparece ese error,¿que puedo hacer?



No será que RED está en mayúsculas?.. sinó vuelve a generar el password para el administrador.. e ingresalo de nuevo..
fíjate si creaste la carpeta correctamentee donde estara el directorio y los permisos necesarios..
Aparentemente todo esta bien --

Salu2 desde Peru

Jaime M. Tan Nozawa
PHP SIG libre

Mi blog de PHP: http://phpexperto.blogspot.com
 
Perfil Sitio Web
 Citar
Milt0n
Publicado en 11/01/08 08:57  

Nuevo
Forum User

Inscrito: 08/01/08 Publicaciones: 12
Sigue igual, ya cambie la contraseña mire las mayusculas y todo igual, veo que este problema pasa muy a menudo pero nadie pone como lo solucionó. ¿tu ya seguiste el manual? alguien le funciono a la perfeccion en su maquina y que maquina era, quien le puede echar un ojo al manual, gracis.




[root@localhost ~]# slappasswd
New password:
Re-enter new password:
{SSHA}st8sJNeC+YNwujHWaKL8/NZiqPOKew1+
[root@localhost ~]# vi /etc/openldap/slapd.conf
[root@localhost ~]# ldapadd -x -W -D 'cn=Administrador, dc=red, dc=com' -h 127.0.0.1 -f base.ldif
Enter LDAP Password:
ldap_bind: Invalid credentials (49)
[root@localhost ~]#
 
Perfil
 Citar
Milt0n
Publicado en 11/01/08 10:41  

Nuevo
Forum User

Inscrito: 08/01/08 Publicaciones: 12
ya solucione el problema.


[root@localhost ~]# service ldap restart
Parando slapd: [ OK ]
Verificando los archivos de configuración para slapd: bdb_db_open: Warning - No DB_CONFIG file found in directory /var/lib/ldap/autenticar: (2)
Expect poor performance for suffix dc=red,dc=com.
config file testing succeeded


en el momento de iniciar el server me daba un error, pues dentro de el directorio autentificar no me encontraba ese archivo, lo que hice fue buscarlo en ldap y meterlo ahi dentro luego volvi a reiniciar el server


[root@localhost ~]# service ldap restart
Parando slapd: [ OK ]
Verificando los archivos de configuración para slapd: config file testing succeeded
[ OK ]
Iniciando slapd: [ OK ]


ahora es cuando el error que me daba ya no esta



[root@localhost ~]# ldapadd -x -W -D 'cn=Administrador, dc=red, dc=com' -h 127.0.0.1 -f base.ldif
Enter LDAP Password:
adding new entry "dc=red,dc=com"

adding new entry "ou=Hosts,dc=red,dc=com"

adding new entry "ou=Rpc,dc=red,dc=com"

adding new entry "ou=Services,dc=red,dc=com"

adding new entry "nisMapName=netgroup.byuser,dc=red,dc=com"

adding new entry "ou=Mounts,dc=red,dc=com"

adding new entry "ou=Networks,dc=red,dc=com"

adding new entry "ou=People,dc=red,dc=com"

adding new entry "ou=Group,dc=red,dc=com"

adding new entry "ou=Netgroup,dc=red,dc=com"

adding new entry "ou=Protocols,dc=red,dc=com"

adding new entry "ou=Aliases,dc=red,dc=com"

adding new entry "nisMapName=netgroup.byhost,dc=red,dc=com"



aun tengo una duda el archivo que no se encontraba en la carpeta DB_CONFIG, necesita alguna configuracion especial? yo puse ese archivo que estaba en /etc/openldap ( DB_CONFIG.exemple )


contiene la siguiente informacion:



# $OpenLDAP: pkg/ldap/servers/slapd/DB_CONFIG,v 1.1.2.3 2006/08/17 17:36:19 kurt Exp $
# Example DB_CONFIG file for use with slapd(8) BDB/HDB databases.
#
# See Sleepycat Berkeley DB documentation
# <http://www.sleepycat.com/docs/ref/env/db_config.html>
# for detail description of DB_CONFIG syntax and semantics.
#
# Hints can also be found in the OpenLDAP Software FAQ
# <http://www.openldap.org/faq/index.cgi?file=2>
# in particular:
# <http://www.openldap.org/faq/index.cgi?file=1075>

# Note: most DB_CONFIG settings will take effect only upon rebuilding
# the DB environment.

# one 0.25 GB cache
set_cachesize 0 268435456 1

# Data Directory
#set_data_dir db

# Transaction Log settings
set_lg_regionmax 262144
set_lg_bsize 2097152
#set_lg_dir logs

# Note: special DB_CONFIG flags are no longer needed for "quick"
# slapadd(8) or slapindex(8) access (see their -q option).





 
Perfil
 Citar
Jaime M. Tan Nozawa
Publicado en 11/01/08 03:13  

Miembro regular
working
Forum User

Inscrito: 31/03/07 Publicaciones: 114
País:Peru
Mas que todo es para controlar la caché y los logs

mas detalles aquí:

http://www.openldap.org/faq/data/cache/1072.html

Salu2 desde Perú

Jaime M. Tan Nozawa
En el 2008 - el OpenSIG será el boom

Mi blog de PHP: http://phpexperto.blogspot.com
 
Perfil Sitio Web
 Citar
Peter
Publicado en 06/10/08 11:21  

Nuevo
Forum User

Inscrito: 06/10/08 Publicaciones: 3
Estoy siguiendo el mismo manual "Cómo configurar OpenLDAP como servidor de autenticación.", he seguido los pasos que se describen en él, pero al momento de ejecutar este comando:

ldapadd -x -w -D 'cn=Administrador, dc=RED, dc=com' -h 127.0.0.1 -f base.ldif

me dio el mensaje: "command not found"

Ayuda por favor Fruncido
 
Perfil
 Citar
saulrainier
Publicado en 07/10/08 06:38  

Participa mucho
Forum User

Inscrito: 28/03/08 Publicaciones: 62
si estas usando centos 5 el comando cambia de ldapadd a slapadd y las opciones tambien revisale con
slapadd --help
 
Perfil
 Citar
Anónimo max2702
Publicado en 13/10/10 03:14  
Hola a todos, siguiendo el manual "Cómo configurar OpenLDAP como servidor de autenticación."
Me ha resultado en principio todo correcto segun el manual, pero cuando quiero añadir una entrada para añadir un usuario
ldapadd -x -W -D 'cn=usuario, dc=sambahost, dc=dominio' -h 192.168.147.11 -f /tmp/group.ldif

ldapadd -x -W -D 'cn=usuario, dc=sambahost, dc=dominio' -h 192.168.147.11 -f /tmp/passwd.ldif

no me deja, me pide el LDAP password, se lo pongo (el que cree con slappasswd)
y me sale el famoso error:
ldap_bind: Invalid credentials (49)

NOTA: Con el root o administrador no me da ningun problema (me sale lo mismo que en el manual).


QUE PUEDE SER?
 
 Citar
Contenido generado en: 0,14 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 04:56 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado