Sistema Operativo ALDOS
Dezoft

Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Redes y Servidores Nuevo tema Publicar Respuesta
 Configuración Squid
Tema anterior Tema siguiente
   
ilidan
Publicado en 05/06/08 05:13 (Leído 3243 veces)  

Participa mucho
working
Forum User

Inscrito: 05/06/08 Publicaciones: 41
País:Ecuador
Saludos, Tengo montado un servidor Linux con CentOS 5 como SO, en el he configurado los siguientes servicios:
- sendmail
- dhcp
- squid
- http

Todos funcionan perfectamente, no tengo mucha experiencia en linux, pero según lo que he visto mi servidor proxy no es transparente porque de hecho cuando quiero que los clientes se conecten al internet necesito agregar en el browser la dirección y el puerto del proxy.

Lo que quiero saber ahora es como hacer que mi proxy se identifique en la red de forma transparente.

Esta es la configuración actual del archivo squid.conf:
#////////////////////////////////////////////////////////////////////////////////
http_port 3128
http_port 8080

hierarchy_stoplist cgi-bin ?

acl QUERY urlpath_regex cgi-bin \?
cache deny QUERY

acl apache rep_header Server ^Apache
broken_vary_encoding allow apache

cache_mem 64 MB

cache_dir ufs /var/spool/squid 700 16 256

access_log /var/log/squid/access.log squid

refresh_pattern ^ftp: 1440 20% 10080
refresh_pattern ^gopher: 1440 0% 1440
refresh_pattern . 0 20% 4320

#Recommended minimum configuration:
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl redlocal src "/etc/squid/ipsallowed" #todos los Ips de la red local
acl redlocal1 src "/etc/squid/ipsdeny" #Ips que estan denegadas el acceso
acl sites_deny url_regex "/etc/squid/sitnegados" #Sitios de internet negados
acl list_extensions urlpath_regex "/etc/squid/filextensions" #Extensiones denegadas
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443 563
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT


http_access allow manager localhost
http_access deny manager

http_access deny !Safe_ports

http_access deny CONNECT !SSL_ports

http_access allow localhost
http_access allow redlocal !redlocal1 !sites_deny !list_extensions
http_access deny all

http_reply_access allow all

icp_access allow all

visible_hostname mi.dominio.com

coredump_dir /var/spool/squid
#////////////////////////////////////////////////////////////////////////////////

La configuración del archivo dhcpd.conf es la siguiente:
#////////////////////////////////////////////////////////////////////////////////
ddns-update-style interim;
ignore client-updates;
shared-network mi.dominio.com {
subnet 196.168.3.0 netmask 255.255.255.0 {
option routers 196.168.3.254;
option subnet-mask 255.255.255.0;
option broadcast-address 196.168.3.255;
option domain-name "mi.dominio.com";
option domain-name-servers xxx.xxx.xxx.xxx,xxx.xxx.xxx.xxx;
option ntp-servers www.pool.ntp.org;
range 196.168.3.200 196.168.3.240;
default-lease-time 21600;
max-lease-time 43200;
}
}

Por favor esperare por sus sabias respuestas y gracias de antemano.

\../_ Metal por sobre todas las cosas _\../
 
Perfil
 Citar
César Octavio Santana García
Publicado en 05/06/08 05:25  

Participa mucho
Forum User

Inscrito: 31/08/07 Publicaciones: 69
Amigo una pregunta, porque tienes dos puertos configurados para que escuche el squid?..

Yo solo configuré de esta manera, para que mi squid escuchara las peticiones por el puerto 8080 y que fuera transparente.

http_port 8080 transparent

espero te sirva. Saludos!
 
Perfil
 Citar
ilidan
Publicado en 05/06/08 05:33  

Participa mucho
Forum User

Inscrito: 05/06/08 Publicaciones: 41
País:Ecuador
Pues es porque me habían dicho que algunos programas que utilizan los usuarios necesitaban ese puerto, yo también sugerí utilizar solamente el puerto 8080, una pregunta, es necesario el transparent después de la definición del puerto..?

http_port 8080 transparent

\../_ Metal por sobre todas las cosas _\../
 
Perfil
 Citar
Samuel
Publicado en 05/06/08 05:42  

Miembro regular
Forum User

Inscrito: 21/02/07 Publicaciones: 70
Si es necesario "transparent" (http_port 8080 transparent) en las versiones recientes de squid. Anteriormente se hacia de otra manera.

Debian la mejor distro. La mayor recopilación de paquetes disponibles con un simple "aptitude install paquete".
 
Perfil
 Citar
ilidan
Publicado en 05/06/08 05:49  

Participa mucho
Forum User

Inscrito: 05/06/08 Publicaciones: 41
País:Ecuador
Pues no amigo, ahorita hice el cambio y probé el squid pero sigo con el problema de que tengo que ingresar en el browser la información del proxy y el puerto al que escucha.

\../_ Metal por sobre todas las cosas _\../
 
Perfil
 Citar
Will Lpz Jimnz
Publicado en 05/06/08 06:01  

Admin
Site Admin

Inscrito: 19/02/07 Publicaciones: 181
País:Mexico
Prueba que por medio de tu dhcp que todos tus clientes tengan como puerta de enlace la IP del servidor Proxy !!

Saludos !! Sr. verde

.:: Cuando el Alumno esta listo, el maestro aparece ::. [[http://koalasoft.wordpress.com ::BLog::]]
 
Perfil Sitio Web
 Citar
ilidan
Publicado en 05/06/08 06:19  

Participa mucho
Forum User

Inscrito: 05/06/08 Publicaciones: 41
País:Ecuador
De hecho creo que con la opción

option routers 196.168.3.254;

estoy asignando ya la puerta de enlace para los clientes por medio del dhcp pero aún así no puedo habilitar el servidor transparente, ya he probado algunas cosas y no he obtenido resultado alguno.

\../_ Metal por sobre todas las cosas _\../
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 05/06/08 06:59  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1742
País:Mexico
Para poner squid como proxy trasnparenbte, adem{as de etablecer http_port 8080 trnasparent, debes combinarlo con reglas de cortafuegos. Se necesitan dos cosas:

1) Que tengas un NAT configurado perfectamente
2) redireccionamiento de peticiones de salida hacia puerto 80 para pasar por puerto 8080.

Detalles en este enlace
 
Perfil Sitio Web
 Citar
ilidan
Publicado en 05/06/08 07:21  

Participa mucho
Forum User

Inscrito: 05/06/08 Publicaciones: 41
País:Ecuador
Pues el redireccionamiento del puerto 80 al 8080 por medio de los iptables si lo tengo y lo de la NAT pues ya voy a leer con detalle el enlace, muchas gracias y cualquier inquietud que surja luego les aviso.

\../_ Metal por sobre todas las cosas _\../
 
Perfil
 Citar
ilidan
Publicado en 06/06/08 05:06  

Participa mucho
Forum User

Inscrito: 05/06/08 Publicaciones: 41
País:Ecuador
Hace un rato estuve configurando nuevamente el archivo squid.conf, reinicié el servicio conjuntamente con el servicio de red y ahí me dí cuenta que el reenvio de paquetes estaba desabilitado, cosa que no me había dado cuenta tiempo atrás y procedí prontamente a activarlo, además gracias al consejo del señor Barrios, que me dijo que redireccione el puerto 80, yo si lo tenía redireccionado pero no con la interfaz correcta, solo tenía que cambiar el redireccionamiento de la interfaz eth1 por la eth0 y eso fue todo, ya tengo mi servidor intermediario transparente funcionando correctamente.

Muchas gracias por sus consejos y sugerencias me sirvieron de mucho.

Hasta la próxima....

\../_ Metal por sobre todas las cosas _\../
 
Perfil
 Citar
Contenido generado en: 0,14 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 06:26 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado