Sondeo

Escritorios alternativos Linux

¿Cuál prefieres?

  •  Xfce
  •  LXDE
  •  Razor-qt
  •  Enlightenment 0.17

Resultados
Other polls | 2,775 voters | 2 comentarios
· Próximas fechas Curso Global de Servidores con CentOS 6.
· Taller de programación de Python.
· Curso de programación de PHP.
· Prueba ALDOS 1.4.5. Nuestro sistema operativo para escritorio.

 Índice del foro > Todo acerca de Linux > Redes y Servidores Nuevo tema Publicar Respuesta
 Problema telnet puerto 25
 
jaguar39
 27/12/08 12:32 (Leído 5418 veces)  
+----
Nuevo
working

Estado: desconectado


Identificado: 25/06/08
Mensajes: 8
Saludos a todos.
Tengo un caso raro, desde un RHE Linux 3 estoy intentando hacer un telnet 25 para probar mi correo saliente y no funciona, despues de un rato marca el siguiente error:

telnet: connect to address : Connection timed out
telnet: Unable to connect to remote host: Connection timed out

es una IP en Internet, a la cual puedo llegar con PING sin problema.
El Linux puede resolver sin problema la IP de ese dominio.

Al principio pense que el problema era que mi ISP estaba bloqueando el puerto 25, pero al hacer la misma prueba desde un equipo Windows que esta en la misma LAN este sí pudo conectarse !!! y el linux no puede :s lo cual me hace pensar que el problema esta en el Linux.
El firewall esta desactivado ( iptables -F ) y en la red obviamente no hay restricciones ya que el Windows si pudo conectarse.

Alguna idea acerca de por que no funcione esa prueba en el Linux ??

Gracias

 
Perfil Correo
 Citar
Francisco Santos
 29/12/08 08:23  
+++--
Miembro participativo

Estado: desconectado


Identificado: 16/12/08
Mensajes: 46
Personalmente no conozco RHEL 3 pero lo que yo probaira seria

1) service iptables stop

telnet mail.servidordecorreo.com 25
telnet mail.servidordecorreocom 110

telnet seguridad.com.mx 25

si con esto no funciona pasamos a lo siguiente

2) telnet 127.0.0.1 22

y nos debe de contestar el puerto de ssh de nuestro pc

si aun asi no funciona yo checaria la seguridad extra que pueda traer RHEL

por ejemplo SELINUX O algo por el estilo

saludos y suerte nos cuentas como te fue..


oink oink oink
 
Perfil Correo
 Citar
jaguar39
 29/12/08 10:55  
+----
Nuevo

Estado: desconectado


Identificado: 25/06/08
Mensajes: 8
Gracias por tu respuesta.
Habia intentado desactivando el firewall ( service iptables stop ) pero no funciono. Segui tu recomendacion y tambien desactive la seguridad de selinux y tampoco funciono Eek!

El telnet localhost 22 funciona sin problema, pero sigo sin poder comunicarme por telnet al puerto 25 del host que gusten ( por ejemplo: yahoo.com.mx, hotmail.com, gmail.com, etc ) Confused

 
Perfil Correo
 Citar
Francisco Santos
 30/12/08 10:01  
+++--
Miembro participativo

Estado: desconectado


Identificado: 16/12/08
Mensajes: 46
bueno si no funciona lo mas probable es que tengas alguna restriccion en el servidor que te da salida hacia internet o que tu iptables este bloqueando tu salida hacia internet...


puedes ejecutar en consola

iptables -nL


y nos posteas el resultado para poderte brindar respuestas mas acertadas..


tambien puedes intentar llegar con telnet a algun servicio de tu red local para ver si es tu servidor de internet el que no deja pasar las peticiones o es la maquina con rhel 3


salu2. suerte

oink oink oink
 
Perfil Correo
 Citar
jaguar39
 04/01/09 08:00  
+----
Nuevo

Estado: desconectado


Identificado: 25/06/08
Mensajes: 8

Claro, te envio el restultado. De hecho no tengo ningun tipo de restriccion por medio de iptables:

[root@localhost ~]# iptables -nL
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
[root@localhost ~]#


De hecho puedo hacer telnet a otros servicios en Internet, por ejemplo:

[root@localhost ~]# telnet hotmail.com 80
Trying 64.4.32.7...
Connected to hotmail.com (64.4.32.7).
Escape character is '^]'.
Connection closed by foreign host.

Pero extrañamente no puedo hacer telnet al puerto 25 de ningun servidor en Internet, ahi esta lo raro Eek!

Saludos.

 
Perfil Correo
 Citar
Eric Partida "jobayks"
 06/01/09 12:12  
MMMMM
Moderador

Estado: desconectado


Identificado: 21/02/07
Mensajes: 9
SELinux esta activado?

**************************** Eric Partida Rodríguez epartida@alcancelibre.org www.alcancelibre.org http://eric-partida-jobayks.blogspot.com
 
Perfil Correo Sitio Web
 Citar
r0man
 06/01/09 06:27  
++---
Suele participar
sore

Estado: desconectado


Identificado: 06/12/08
Mensajes: 32
Saludos..

Puedes verificar tambien las envolturas TCP (tcp wrappers) en los archivos /etc/host.allow y /etc/host.deny. si tienes alguna entrada posteala..

Es raro el caso, pero es una posibilidad.

 
Perfil Correo
 Citar
jaguar39
 06/01/09 08:24  
+----
Nuevo

Estado: desconectado


Identificado: 25/06/08
Mensajes: 8

SELinux esta desactivado ( al menos eso entiendo ). Lo hice con la siguiente instruccion:

[root@localhost ~]# echo 0 >/selinux/enforce



En el archivo /etc/hosts.allow tengo "ALL:ALL"
El archivo /etc/hosts.deny esta vacio.


Saludos

 
Perfil Correo
 Citar
Eric Partida "jobayks"
 08/01/09 12:25  
MMMMM
Moderador

Estado: desconectado


Identificado: 21/02/07
Mensajes: 9
Tienes SELinux activado, eso no quiere decir que este mal, solo que hay que aprender a utilizarlo.

Es posible que tu problema sea por eso, habria que tener mas datos para saber que ocurre.

De cualquier forma desactivalo para verificar si es eso.

Edita /etc/selinux/

y deja disabled SELINUX


SELINUX=disabled


No confundir con SELINUXTYPE


Guarda cambios y tendras que reiniciar.


Saludos

**************************** Eric Partida Rodríguez epartida@alcancelibre.org www.alcancelibre.org http://eric-partida-jobayks.blogspot.com
 
Perfil Correo Sitio Web
 Citar
jaguar39
 10/01/09 01:01  
+----
Nuevo

Estado: desconectado


Identificado: 25/06/08
Mensajes: 8

Ok, mi archivo quedo de la siguiente forma:

[root@localhost selinux]# pwd
/etc/selinux
[root@localhost selinux]# cat config
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - SELinux is fully disabled.
#SELINUX=enforcing
SELINUX=disabled
# SELINUXTYPE= type of policy in use. Possible values are:
# targeted - Only targeted network daemons are protected.
# strict - Full SELinux protection.
SELINUXTYPE=targeted


Reinicie el equipo y sigue igual Frown simplemente se queda esperando respuesta:


[root@localhost selinux]# telnet hotmail.com 25
Trying 64.4.32.7...

[root@localhost selinux]#


Saludos

 
Perfil Correo
 Citar
Kwame Bahena
 13/01/09 05:50  
+----
Nuevo

Estado: desconectado


Identificado: 03/03/07
Mensajes: 5
Será que no tienes nada escuchando en el puerto 25?

Que te dice

netstat -luntp | grep -i listen

?

-- kwame
 
Perfil Correo Sitio Web
 Citar
Contenido generado en: 0,16 segundos
Nuevo tema Publicar Respuesta


Tema normal Tema normal
Tema Pegado Tema Pegado
Tema bloqueado Tema bloqueado
Mensaje Nuevo Mensaje Nuevo
Tema pegado con nuevo mensaje Tema pegado con nuevo mensaje
Tema bloqueado con nuevo mensaje Tema bloqueado con nuevo mensaje
Ver mensajes anónimos 
Los usuarios anónimos pueden enviar 
Se permite HTML Filtrado 
Contenido censurado