Cursos Servidores con Centos 6
Sistema Operativo ALDOS
Dezoft

Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Redes y Servidores Nuevo tema Publicar Respuesta
 Mi servidor no recibe correos externos
Tema anterior Tema siguiente
   
Perseus
Publicado en 10/02/09 01:04 (Leído 8996 veces)  

Miembro regular
Forum User

Inscrito: 02/08/07 Publicaciones: 115
País:Chiapas, México
Hola todos tengo un servidor Centos 5.2 configurado según el manual de este sitio y envía y recibe correos sin problema cuando es entre cuentas del mismo servidor, pero si alguien me escribe desde algún servidor comercial de correos yo no recibo nada. ¿Cómo puedo revisar que está sucediendo para resolver este problema? Alguna idea.

Gracias de antemano a todos.

--------------------o00o-----| º L º |-------o00o-------------------- También en la Selva existen los pingúinos!!
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 10/02/09 01:52  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1727
País:Mexico
¿estáss en una IP fija o dinámica?

¿Cómo está configurados los registros MX de tu zona de DNS?

¿Hacia donde apuntan los registros A de los servidores de correo que están como registro MX en la zona de DNS?

¿Qué mensajes de error se devuelven en hotmail, yahoo o gmail?

¿Añadiste el nombre de tu dominio en /etc/mail/local-host-names?
 
Perfil Sitio Web
 Citar
Perseus
Publicado en 10/02/09 03:41  

Miembro regular
Forum User

Inscrito: 02/08/07 Publicaciones: 115
País:Chiapas, México
Gracias por responder Joel, respondiendo a tus preguntas:

1.- Es una ip fija

2 y 3.- Mi DNS está configurado asi:
<pre>-------------------------------------------------------------
$TTL 86400
@ IN SOA quetzal.midominio.edu.mx. jruizs.dominio2.edu.mx. (
2009012106 ; serial
28800 ; refresh
7200 ; retry
604800 ; expire
86400 ; ttl
)
@ IN NS dns
@ IN MX 10 mail
@ IN A xxx.xxx.100.67
quetzal IN A xxx.xxx.100.67
www IN CNAME xxx.xxx.100.67
mail IN A xxx.xxx.100.67
dns IN CNAME xxx.xxx.100.67
tapir IN A xxx.xxx.100.68
------------------------------------------------------------------
</pre>

4.-En Hotmail, Yahoo o Gmail no me aparece ningún error, según parece el correo se envía bien.

5.- Si añadí el nombre de mi dominio a /etc/mail/local-host-names

--------------------o00o-----| º L º |-------o00o-------------------- También en la Selva existen los pingúinos!!
 
Perfil
 Citar
Perseus
Publicado en 10/02/09 06:51  

Miembro regular
Forum User

Inscrito: 02/08/07 Publicaciones: 115
País:Chiapas, México
Ya puedo enviar y recibir correos a Gmail, pero no al Yahoo o al Hot... veo esto en los logs
<pre>------------------------------------------------------

Feb 9 19:46:09 quetzal sendmail[3792]: AUTH=server, relay=dsl-189-133-161-104.prod-infinitum.com.mx [189.133.161.104] (may be forged), authid=fulano, mech=LOGIN, bits=0
Feb 9 19:46:10 quetzal sendmail[3792]: n1A1k2jY003792: from=<fulano@midominio.edu.mx>, size=3536, class=0, nrcpts=1, msgid=<1954F476037745F195E4ED52682EA44E@PerseuS>, proto=ESMTP, daemon=MSA, relay=dsl-189-133-161-104.prod-infinitum.com.mx [189.133.161.104] (may be forged)
Feb 9 19:46:11 quetzal sendmail[3794]: n1A1k2jY003792: to=<micuenta@hotmail.com>, ctladdr=<fulano@midominio.edu.mx> (516/516), delay=00:00:01, xdelay=00:00:01, mailer=esmtp, pri=123536, relay=mx2.hotmail.com. [65.54.245.40], dsn=2.0.0, stat=Sent ( <1954F476037745F195E4ED52682EA44E@PerseuS> Queued mail for delivery)
---------------------------------------------------------</pre>

Gracias de antemano Sonrisa

--------------------o00o-----| º L º |-------o00o-------------------- También en la Selva existen los pingúinos!!
 
Perfil
 Citar
Perseus
Publicado en 10/02/09 03:32  

Miembro regular
Forum User

Inscrito: 02/08/07 Publicaciones: 115
País:Chiapas, México
Ya me llegó un error,

<pre> ----- Transcript of session follows -----
<fulano@midominio.edu.mx>... Deferred: Connection timed out with mail.midominio.edu.mx.
Warning: message still undelivered after 4 hours
Will keep trying until message is 5 days old</pre>

Saludos y gracias nuevamente

--------------------o00o-----| º L º |-------o00o-------------------- También en la Selva existen los pingúinos!!
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 10/02/09 03:48  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1727
País:Mexico
Quote by: Perseus

Ya me llegó un error,

<pre>----- Transcript of session follows -----
<fulano@midominio.edu.mx>... Deferred: Connection timed out with mail.midominio.edu.mx.
Warning: message still undelivered after 4 hours
Will keep trying until message is 5 days old</pre>

Saludos y gracias nuevamente




Ese solo indica que no puede encontrar mail.dominio.edu.mx.

¿Que servidores DNS pusiste en /etc/resolv.conf?

¿Los servidores DNS en /etc/resolv.conf resuelven correctamente? Sugiero verifiques manualmente uno por uno con el mandato host de este modo: host algo.algo xx.xx.xx.xx

Mira dentro de /var/spool/mqueue. Es la cola de salida con todos los mensajes que no se han entregado. encontraras dos tipos de archivos, por parejas, los que tiene las cabeceras de estado del mensaje empiezan con Q o q, los otros son el cuerpo del mensaje. Examina a detalle el contenido de varios al azar.

Desde otro servidor que funcione correctamente, envía mensaje al tuyo y determina si devuelve algún mensje de error a postmaster o bien si se registra algo anormal en /var/log/maillog.

Lo ideal es que para hacer las pruebas, dejes abierto /var/log/maillog con tail -f en ambos servidores al momento de hacer las pruebas diagnósticas.
 
Perfil Sitio Web
 Citar
Perseus
Publicado en 10/02/09 05:31  

Miembro regular
Forum User

Inscrito: 02/08/07 Publicaciones: 115
País:Chiapas, México
Joel, nuevamente gracias por responder.

Probe los dns que tengo en /etc/resolv y todos funcionaron bien, excepto el propio servidor que está configurado como dns también. Me aparece esto:

<pre>host hotmail.com xxx.xxx.100.67
Using domain server:
Name: xxx.xxx.100.67
Address: xxx.xxx.100.67#53
Aliases:

------------------------------</pre>

En el servidor no me aparece nada en la carpeta /var/spool/mqueue

------------------------------

En el otro servidor me aparece:

<pre>----------------------------------------------------------
[root@tonina mqueue]# more qfn1AGZdD1032580
V8
T1234283739
K1234283784
N1
P120398
I3/5/71279
MDeferred: Connection timed out with mail.dominio.edu.mx.
Fbs
$_tonina.otrodominio.edu.mx [127.0.0.1]
$rESMTP
$stonina.otrodominio.edu.mx
${daemon_flags}
${if_addr}127.0.0.1
S<jruizs@tonina.otrodominio.edu.mx>
A<>
MDeferred: Connection timed out with mail.dominio.edu.mx.
rRFC822; fulano@dominio.edu.mx
RPFD:<fulano@dominio.edu.mx>
H?P?Return-Path: <g>
H??Received: from tonina.otrodominio.edu.mx (tonina.otrodominio.edu.mx [127.0.0.1])
by tonina.otrodominio.edu.mx (8.13.1/8.13.1) with ESMTP id n1AGZdD1032580
for <fulano@dominio.edu.mx>; Tue, 10 Feb 2009 10:35:39 -0600
H?x?Full-Name: Perseus Fulano Sutano
H??Received: (from fulano@localhost)
by tonina.otrodominio.edu.mx (8.13.1/8.13.1/Submit) id n1AGZd1L032579
for fulano@dominio.edu.mx; Tue, 10 Feb 2009 10:35:39 -0600
H??Date: Tue, 10 Feb 2009 10:35:39 -0600
H??From: Perseus Fulano Sutano <fulano@tonina.otrodominio.edu.mx>
H??Message-Id: <200902101635.n1AGZd1L032579@tonina.otrodominio.edu.mx>
H??To: fulano@dominio.edu.mx
H??Subject: Hola desde la selva
.

-------------------------------------------------------------------</pre>


Revisaré de nuevo mis archivos de configuración pero agradecería nuevamente tu ayuda.

Saludos

--------------------o00o-----| º L º |-------o00o-------------------- También en la Selva existen los pingúinos!!
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 10/02/09 06:18  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1727
País:Mexico
Al parecer el problema es tu DNS, aunque habría que revisar contenidos de cabeceras en /var/spool/mqueue para corroborar.

Tu DNS parece que no contesta consultas recursivas para si mismo. Lo que debes hacer es editar named.conf y añadir en la sección de opciones (es decir options { ... }Guiño el parámetro allow-recursion para permitir a tu LAN, tu propia IP pública y retorno del sistema.

allow-recursion { 127.0.0.1/32; 192.168.1.0/24; xxx.xxx.100.67/xx; };

Para asegurar que siempre haya respuestas, también añade forwarders en la misma sección, de modo que definas que tu DNS reeenvie las consultas los servidores DNS del proveedor cuando no se posible responder una consulta:

forwarders { xxx.xxx.xxx.xxx; xxx.xxx.xxx.xxx; };

Lo anterior debe permitir a tu servidor DNS local poder realizar consultas recursivas a si mismo y utilizar los DNS de tu proveedor cuando sea necesario.

 
Perfil Sitio Web
 Citar
Perseus
Publicado en 11/02/09 01:03  

Miembro regular
Forum User

Inscrito: 02/08/07 Publicaciones: 115
País:Chiapas, México
Estimado Joel, agregue al /etc/named.conf las líneas que me comentaste, ya me resuelve mi propio servidor dns:

<pre>-------------------------------------------------------------
[root@quetzal ~]# host www.hotmail.com xxx.xxx.100.67
Using domain server:
Name: xxx.xxx.100.67
Address: xxx.xxx.100.67#53
Aliases:

www.hotmail.com is an alias for mail.live.com.
mail.live.com has address 64.4.38.249
mail.live.com has address 65.55.130.121
mail.live.com has address 65.55.131.121
mail.live.com has address 65.55.132.121
mail.live.com has address 207.46.8.121
mail.live.com has address 207.46.8.249
mail.live.com has address 207.46.9.121
mail.live.com has address 207.46.9.249
mail.live.com has address 207.46.10.121
mail.live.com has address 207.46.10.249
mail.live.com has address 207.46.11.121
mail.live.com has address 207.46.11.249
-----------------------------------------------------------</pre>

Pero aún sigo con el mismo problema... desactivé el firewall y parece que con eso por momento recibo algunos correos y mando algunos.. pero aún no queda como debe ser...
seguimos intentando. Nuevamente gracias Joel..

Cuando vengas de nuevo a Ocosingo, recuerdame que te mande un quesito extra Razz

--------------------o00o-----| º L º |-------o00o-------------------- También en la Selva existen los pingúinos!!
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 11/02/09 06:05  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1727
País:Mexico
Si ese es el caso, revisa la configuración de tu cortafuegos para que permita tráfico entrante por el puerto 25.

Otros puertos que sugiero abras o verifiques estén abiertos, si es que los usas...

25 (smtp)
110 (pop3)
143 (imap)
465 (smtps)
587 (submission)
993 (imaps)
995 (pop3s)

Si lo deseas, puedo auxiliarte revisando tu cortafuegos y configuración de sendmail remotamente, por ssh. Solo contactame por mensajero o al 55-5677-7130.
 
Perfil Sitio Web
 Citar
Contenido generado en: 0,20 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 09:17 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado