Sistema Operativo ALDOS
Dezoft

Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Redes y Servidores Nuevo tema Publicar Respuesta
 Hora en SQUID
Tema anterior Tema siguiente
   
pulgaman
Publicado en 05/03/09 05:13 (Leído 4321 veces)  

Nuevo
Forum User

Inscrito: 28/02/09 Publicaciones: 8
Hola a todos

Tengo un Servidor Squid Proxy funcionando en mi red. El problema que tengo es que dentro del anuncio del bloqueo la hora mostrada es incorrecta.

Por ejemplo si son las 11:06am y si realizo una peticion a una página bloqueada dentro del error me manda la siguiente hora:

Generated Thu, 05 Mar 2009 17:06:15 GMT by fw (squid/2.6.STABLE18)

Verificando en el servidor tengo estos datos:

root@fw:/$ date
jue mar 5 11:03:47 CST 2009
root@fw:/$ date -u
jue mar 5 17:03:49 UTC 2009


Por lo que asumo que esta tomando el horario UTC en vez del horario del sistema. Para mi es superimportante que este el horario del SQUID al dia, ya que tengo instalado tambien SARG para el reporteo de acceso y las horas mostradas, no coinciden en realidad con la hora real en la que el usuario realizo la petición.

Ojala me puedan ayudar a corregir esto.

Saludos.
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 05/03/09 08:33  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1755
País:Mexico
¿Cómo tienes configurada la hora y fecha en tu sistema?

 
Perfil Sitio Web
 Citar
pulgaman
Publicado en 05/03/09 08:57  

Nuevo
Forum User

Inscrito: 28/02/09 Publicaciones: 8
Gracias por contestar Joel

La hora en mi sistema en el timezone la tengo configurada de la siguiente manera:

America/Mexico_City

Lo estoy manejando todo en consola, no tengo ningun adm de escritorio. Lo mas raro es que la hora del sistema si esta correcta como muestro en la sig. lineas:

root@fw:/etc$ date
jue mar 5 14:51:54 CST 2009
root@fw:/etc$ uptime
14:51:57 up 2 days, 7:50, 1 user, load average: 0.00, 0.00, 0.00


Pero el SQUID toma la hora UTC del servidor

root@fw:/etc$ date -u
jue mar 5 20:53:09 UTC 2009


Como pueden ver la UTC va adelantada 6hrs mas, me imagino q es por el GMT-6, pero no se como hacer que el SQUID tome la del sistema y no la UTC.

Saludos.
 
Perfil
 Citar
Anónimo ahv80
Publicado en 18/01/16 06:39  
Citando a: pulgaman

root@fw:/etc$ date
jue mar 5 14:51:54 CST 2009
root@fw:/etc$ uptime
14:51:57 up 2 days, 7:50, 1 user, load average: 0.00, 0.00, 0.00


Pero el SQUID toma la hora UTC del servidor

root@fw:/etc$ date -u
jue mar 5 20:53:09 UTC 2009


Como pueden ver la UTC va adelantada 6hrs mas, me imagino q es por el GMT-6, pero no se como hacer que el SQUID tome la del sistema y no la UTC.


Hola, veo que la pregunta no fue contestada y ya lleva algún tiempo pero me pasa algo similar y me gustaría saber si pudiste resolverlo o alguien que sepa dar una solución.

Tengo una aplicación contable, mas precisamente CGUNO montado en un servidor CentOS v5.8.
Cuando se generan algunos reportes especiales, el reporte muestra la hora UTC y no la del sistema.
Por consola cuando ejecuto el comando date me muestra la hora correcta, cuando ejecuto el comando date -u me muestra una hora que esta 6 horas por encima de la actual.
He verificado que la zona horaria este correcta, he verificado que la hora del sistema coincida con la hora del hardware, he cambiado hasta la pila de la BIOS del servidor pero no encuentro una solución lógica.

Alguien que pueda ayudar?
 
 Citar
Joel Barrios Dueñas
Publicado en 20/01/16 08:23  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1755
País:Mexico
No, no lleva mucho tiempo sin contestarse. La respuesta está publicada en la sección de manuales de este sitio desde hace muchos años.

http://www.alcancelibre.org/staticpages/index.php/ajuste-zona-horaria-fecha-hora

Por favor evita publicar nuevas preguntas en hilos que no iniciaste tu mismo. Debiste publicar tu pregunta como nuevo tema.

Hola, veo que la pregunta no fue contestada y ya lleva algún tiempo pero me pasa algo similar y me gustaría saber si pudiste resolverlo o alguien que sepa dar una solución.

Tengo una aplicación contable, mas precisamente CGUNO montado en un servidor CentOS v5.8.
Cuando se generan algunos reportes especiales, el reporte muestra la hora UTC y no la del sistema.
Por consola cuando ejecuto el comando date me muestra la hora correcta, cuando ejecuto el comando date -u me muestra una hora que esta 6 horas por encima de la actual.
He verificado que la zona horaria este correcta, he verificado que la hora del sistema coincida con la hora del hardware, he cambiado hasta la pila de la BIOS del servidor pero no encuentro una solución lógica.

Alguien que pueda ayudar?
 
Perfil Sitio Web
 Citar
Contenido generado en: 0,11 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 02:38 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado