Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Manuales y documentos Nuevo tema Publicar Respuesta
 Problema aplicando Manual Samba LDAP Centos 5(Could not start_tls)
Tema anterior Tema siguiente
   
Nelson C.
Publicado en 10/11/09 04:23 (Leído 5017 veces)  

Nuevo


Estado: desconectado
Forum User

Inscrito: 19/11/08
Publicaciones: 6
País:Santo Domingo
SALUDOS a TODOS

Desde hace un buen tiempo he tratado de finalizar con exito pero no he podido, segun el manual que he siguido paso a paso y sin activar SSL en niguna de mis configuracion:
http://www.alcancelibre.org/staticpages/index.php/SAMBALDAP-CENTOS5

Pero me he quedado parado en el comando:
smbldap-populate -a Administrador

Me da esta SALIDA:
[root@nodo1 ~]# smbldap-populate -a admin
Populating LDAP directory for domain MTD-TEST (S-1-5-21-1535157019-3473642487-957866860)
(using builtin directory structure)

Use of uninitialized value in string at /usr/sbin//smbldap_tools.pm line 334.
Use of uninitialized value in string at /usr/sbin//smbldap_tools.pm line 334.
Use of uninitialized value in string at /usr/sbin//smbldap_tools.pm line 334.
Use of uninitialized value in string at /usr/sbin//smbldap_tools.pm line 334.
Could not start_tls: unsupported extended operation at /usr/sbin//smbldap_tools.pm line 341.

TAMBIEN ME DA ESTE ERROR CUANDO CORRO ESTE COMANDO:

[root@nodo1 ~]# net groupmap list
[2009/11/09 23:32:08, 0] passdb/pdb_ldap.c:ldapsam_setsamgrent(3107)
ldapsam_setsamgrent: LDAP search failed: No such object
[2009/11/09 23:32:08, 0] passdb/pdb_ldap.c:ldapsam_enum_group_mapping(3179)
ldapsam_enum_group_mapping: Unable to open passdb

Anteriomente corri el comando smbpasswd -a root, no se si el problema esta por aqui.
aunque luego corri el comando corespondiente:
slappasswd -h {MD5}

Aunque ya he visitado el foro aqui pero no da una solucion al problema:
http://www.alcancelibre.org/forum/viewtopic.php?showtopic=2096

AYUDA, con este problema, AYUDA, GRACIAS


http://blogs.clavedigital.com/ncastillo
 
Perfil Sitio Web
 Citar
Nelson C.
Publicado en 10/11/09 04:28  

Nuevo

Estado: desconectado
Forum User

Inscrito: 19/11/08
Publicaciones: 6
País:Santo Domingo
NOTA: en el comando : smbldap-populate -a admin tambien puede ser: smbldap-populate -a adminitrator ya que estan registrado en /etc/samba/smbusers

http://blogs.clavedigital.com/ncastillo
 
Perfil Sitio Web
 Citar
Nelson C.
Publicado en 10/11/09 04:50  

Nuevo

Estado: desconectado
Forum User

Inscrito: 19/11/08
Publicaciones: 6
País:Santo Domingo
ENCOTRE LA SOLUCION: Comente las siguiente lineas en /etc/smbldap-tools/smbldap.conf y todos los paso siguiente pasanron Bien. vim /etc/smbldap-tools/smbldap.conf # Use TLS for LDAP # If set to 1, this option will use start_tls for connection # (you should also used the port 389) # If not defined, parameter is set to "0" # ldapTLS="1" # Use SSL for LDAP # If set to 1, this option will use SSL for connection # (standard port for ldaps is 636) # If not defined, parameter is set to "0" # ldapSSL="0" # How to verify the server's certificate (none, optional or require) # see "man Net::LDAP" in start_tls section for more details # verify="optional" # CA certificate # see "man Net::LDAP" in start_tls section for more details # cafile="/etc/smbldap-tools/ca.pem" # certificate to use to connect to the ldap server # see "man Net::LDAP" in start_tls section for more details # clientcert="/etc/smbldap-tools/smbldap-tools.iallanis.info.pem" # key certificate to use to connect to the ldap server # see "man Net::LDAP" in start_tls section for more details # clientkey="/etc/smbldap-tools/smbldap-tools.iallanis.info.key" RESULTADOS DEPUES DE COMENTAR LAS LINEAS MENCIONADA ARRIBA: [root@nodo1 samba]# smbldap-populate -a Administrator Populating LDAP directory for domain MTD-TEST (S-1-5-21-1535157019-3473642487-9578 66860) (using builtin directory structure) adding new entry: dc=mtd-test,dc=local adding new entry: ou=Users,dc=mtd-test,dc=local adding new entry: ou=Groups,dc=mtd-test,dc=local adding new entry: ou=Computers,dc=mtd-test,dc=local adding new entry: ou=Idmap,dc=mtd-test,dc=local adding new entry: uid=Administrator,ou=Users,dc=mtd-test,dc=local adding new entry: uid=nobody,ou=Users,dc=mtd-test,dc=local adding new entry: cn=Domain Admins,ou=Groups,dc=mtd-test,dc=local adding new entry: cn=Domain Users,ou=Groups,dc=mtd-test,dc=local adding new entry: cn=Domain Guests,ou=Groups,dc=mtd-test,dc=local adding new entry: cn=Domain Computers,ou=Groups,dc=mtd-test,dc=local adding new entry: cn=Administrators,ou=Groups,dc=mtd-test,dc=local adding new entry: cn=Account Operators,ou=Groups,dc=mtd-test,dc=local adding new entry: cn=Print Operators,ou=Groups,dc=mtd-test,dc=local adding new entry: cn=Backup Operators,ou=Groups,dc=mtd-test,dc=local adding new entry: cn=Replicators,ou=Groups,dc=mtd-test,dc=local adding new entry: sambaDomainName=MTD-TEST,dc=mtd-test,dc=local Please provide a password for the domain Administrator: Changing UNIX and samba passwords for Administrator New password: Retype new password: [root@nodo1 samba]# net groupmap list Domain Admins (S-1-5-21-1535157019-3473642487-957866860-512) -> 512 Domain Users (S-1-5-21-1535157019-3473642487-957866860-513) -> 513 Domain Guests (S-1-5-21-1535157019-3473642487-957866860-514) -> 514 Domain Computers (S-1-5-21-1535157019-3473642487-957866860-515) -> 515 Administrators (S-1-5-32-544) -> 544 Account Operators (S-1-5-32-548) -> 548 Print Operators (S-1-5-32-550) -> 550 Backup Operators (S-1-5-32-551) -> 551 Replicators (S-1-5-32-552) -> 552

http://blogs.clavedigital.com/ncastillo
 
Perfil Sitio Web
 Citar
Nelson C.
Publicado en 10/11/09 07:13  

Nuevo

Estado: desconectado
Forum User

Inscrito: 19/11/08
Publicaciones: 6
País:Santo Domingo
Tengo ahora otro problema: y es que no puedo registrar los clientes de Window$ XP Alguien sabe or que? Rolling Eyes

http://blogs.clavedigital.com/ncastillo
 
Perfil Sitio Web
 Citar
tomasecastro
Publicado en 26/01/12 04:09  

Nuevo

Estado: desconectado
Forum User

Inscrito: 23/01/12
Publicaciones: 1
Actualmente estoy implementando un servidor LDAP+SAMBA+SSL. Siguiendo la guia que indicas y otra informacion adicional. Lo logre hacer trabajar LDAP y que solo funcione por el puerto 636, con certificados digitales. Pero al tratar de unir un equipo a mi dominio me indica que el usuario no existe. Al verificar Observo que si creo el registro del equipo en el LDAP. Pero en el log del LDAP observe que me esta tratando de hacer una consulta a la OU que estableci para los usuarios. Si alguien tiene una informacion actualizada de como hacer funcionar el SAMBA+LDAP como PDC correctamente se lo agradesco. Tambien aprovecho para ofrecer mi manual y mejorar el actual. Esperando su pronta ayuda y agradeciendo por adelantado, Tomas Castro
 
Perfil
 Citar
Contenido generado en: 0,10 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 11:24 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado