Cursos Servidores con Centos 6
Sistema Operativo ALDOS
Dezoft

Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Redes y Servidores Nuevo tema Publicar Respuesta
 Red inaccesible???
Tema anterior Tema siguiente
   
sodablack
Publicado en 23/03/11 06:06 (Leído 20871 veces)  

Nuevo
working
Forum User

Inscrito: 18/02/11 Publicaciones: 13
K tal amigos, buen dia

Comienzo por darle las gracias al buen Joel, efectivamente gracias a las reglas que me proporciono pude resolver el detalle de conexion, por ahi tuve un pequeño problemita ya que si tenia respuesta hacia el internet desde el shell, pero en los navegadores no, lo resolvi agregando el puerto 80 en la linea del fw2net.

Ya puedo conectarme a internet desde mi area local, ahora me surge una duda, los ping desde mi dmz a la interfaz de red de la dmz funcionan correctamente, pero a mi area local no funcionan, tampoco tengo salida a internet desde mi dmz.

al momento de hacer un ping por ejemplo:

ping 192.168.3.1 => (interfaz de red de la DMZ)funciona perfectamente
ping 192.168.10.1 => (interfaz de red Local)Red inaccesible
ping 192.168.10.15 => (equipo dentro de la red local) Red inaccesible
ping www.google.com.mx => host desconocido

Por favor si estoy haciendo algo mal, corrijanme o ayudenme a entenderlo un poco mejor. Les agradesco mucho Gracias.
 
Perfil
 Citar
sodablack
Publicado en 23/03/11 07:13  

Nuevo
Forum User

Inscrito: 18/02/11 Publicaciones: 13
k tal buen dia

he tratado de indagar que puede estar ocasionando que no vea al resto de mis redes pero nomas no veo claro.

les explico detalladamente:

192.168.1.50 (dir. ip de mi gateway)
192.168.10.1 (dir. ip de mi lan)
192.168.3.1 (dir. ip de mi dmz)

de mi red lan con equipo windows funciona perfecto, pero mi dmz no tengo salida a internet ni a pings, me arroja red inaccesible o host desconocido.

con el comando route -n me aparecen estas dos lineas, lo cual me hace pensar que no se esta agregando mi gateway

#route -n
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.3.3 0.0.0.0 255.255.255.255.0 u 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 u 0 0 0 eth0

para agregar la dir. ip del gateway hago lo siguiente:

route add -net 0.0.0.0 netmask 0.0.0.0 gw 192.168.1.50 eth0
SIOCADDRT: La red es inaccesible

route add default gw 192.168.1.50
SIOCADDRT: La red es inaccesible

di de baja las tarjetas de red de mi dmz y las reinicie y nada, borre todos los valores los volvi a poner y nada. alguien tendra alguna idea de como solucionar este pequeño gran detalle, me gustaria alojar un sitio web en el ser. de mi dmz

Gracias

 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 24/03/11 07:14  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1725
País:Mexico
Añade a /etc/shorewall/rules:

PHP Formatted Code
ACCEPT    loc      dmz      icmp      8
ACCEPT    dmz      loc      icmp      8


De igual forma, cualquier otro servicio que quieras abrir de la LAN a la DMZ, aplicaría algo muy similar. Ejemplo, para permitir el acceso de la LAN a un servidor HTTP en la DMZ:

PHP Formatted Code
ACCEPT    loc      dmz:192.168.3.5      tcp      80


Cosa de aplicar un poco de lógica y ejemplos como los anteriores.
 
Perfil Sitio Web
 Citar
sodablack
Publicado en 24/03/11 07:32  

Nuevo
embarrassed
Forum User

Inscrito: 18/02/11 Publicaciones: 13
ya todo lo que me has mencionado anteriormente lo he realizado Joel, de hecho he realizado pruebas desde un equipo en Windows, con los mismos parametros de red que en la DMZ y no tengo ningun problema, tengo salida a internet, hay ping, paso por el squid, etc.

pero en mi servidor Centos, no tengo salida, cualquier ping me arroja red desconocida o host desconocido, solo tengo salida a la interfaz de la dmz.

no creo que sea el shorewall de hecho estoy seguro, sino tendria problemas al conectarme desde windows, he probado varias cosas, agregar el gateway, hasta cambie el cable, ayudame porfa, no quiero formatear, pero ya el tiempo lo tengo encima y nologro encontrar el error. espero puedas ayudarme Gracias.
 
Perfil
 Citar
sodablack
Publicado en 29/03/11 02:16  

Nuevo
Forum User

Inscrito: 18/02/11 Publicaciones: 13
Buenos dias

he encontrado el error a mi problema, mi red era inaccesible ya que mi puerta de enlace se encontraba fuera del alcance, con los parametros de red 192.168.3.3 con puerta de enlace 192.168.1.50, solo cambie la puerta de enlace a 192.168.3.1 y todo perfecto. el firewall esta funcionando perfecto y el squid tambien. Les agradesco mucho y nos vemos mas adelante Gracias.
 
Perfil
 Citar
Contenido generado en: 0,31 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 09:36 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado