Sistema Operativo ALDOS
Dezoft

Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Programación y desarrollo Nuevo tema Publicar Respuesta
 php-mssql 5.2.10
Tema anterior Tema siguiente
   
eroblero
Publicado en 05/11/11 08:17 (Leído 3060 veces)  

Participa mucho
Forum User

Inscrito: 27/04/07 Publicaciones: 42
Buenas tardes colegas. Estoy dándome de topes tratando de instalar el modulo php-mssql y no logro instalar la versión que corresponde a mi versión de PHP. Tengo Centos 5.7 i386 y la versión de PHP es la 5.2.10. Con yum install php-mssql me instala la versión 5.1.6 del módulo. No marca error la instalación pero al reiniciar httpd en el log marca el siguiente error: PHP Warning: PHP Startup: mssql: Unable to initialize module\nModule compiled with module API=20050922, debug=0, thread-safety=0\nPHP. He buscado el rpm de php-mssql-2.5.10 para Centos 5 sin tener éxito. He encontrado dos que al tratar de instalarlos me dicen que hay error de dependencias pues requieren php-common-5.2.10-1 y es precisamente la versión que tengo. Agradezco de antemano su valioso apoyo.
 
Perfil
 Citar
eroblero
Publicado en 07/11/11 07:22  

Participa mucho
Forum User

Inscrito: 27/04/07 Publicaciones: 42
Buenas tardes.
Logré resolverlo siguiendo los pasos de este sitio:
http://www.howtoforge.com/installing_php_mssql_centos5.0
El único detalle es que tuve que desinstalar postgresql 8.4, que ya lo tenia funcionando. En su lugar instalé postgresql 8.1 para poder hacer el rpm ya que marcaba conflicto de versiones.
Gracias.
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 08/11/11 03:00  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1742
País:Mexico
Quitate de problemas. Desinstala lo que hayas puesto. Añade los almacenes yum de EPEL (https://fedoraproject.org/wiki/EPEL) y los de Remi Collet (http://rpms.famillecollet.com/enterprise/5/), e instala PHP 5.3, ejecutando:

PHP Formatted Code
yum remove php-*
yum -y install php53-*
 
Perfil Sitio Web
 Citar
anroswell
Publicado en 08/11/11 07:58  

Nuevo
Forum User

Inscrito: 08/11/11 Publicaciones: 5
Quote by: Joel+Barrios+Due%C3%B1as

Quitate de problemas. Desinstala lo que hayas puesto. Añade los almacenes yum de EPEL (https://fedoraproject.org/wiki/EPEL) y los de Remi Collet (http://rpms.famillecollet.com/enterprise/5/), e instala PHP 5.3, ejecutando:

PHP Formatted Code
yum remove php-*
yum -y install php53-*



Amigo una pregunta con relacion a tu respuesta, como hago esto q dices

Añade los almacenes yum de EPEL (https://fedoraproject.org/wiki/EPEL) y los de Remi Collet (http://rpms.famillecollet.com/enterprise/5/), e instala PHP 5.3,
???????

De antemano garcias por tu respuesta.
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 08/11/11 10:16  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1742
País:Mexico
PHP Formatted Code
rpm -Uvh http://download.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
rpm -Uvh  http://rpms.famillecollet.com/enterprise/remi-release-5.rpm
yum remove php-*
yum -y install --enablerepo=remi php53-*
 
Perfil Sitio Web
 Citar
eroblero
Publicado en 09/11/11 03:40  

Participa mucho
Forum User

Inscrito: 27/04/07 Publicaciones: 42
Gracias Joel.
Seguiré tu consejo.
Saludos.
 
Perfil
 Citar
Contenido generado en: 0,50 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 05:26 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado