Cursos Servidores con Centos 6
Sistema Operativo ALDOS
Dezoft

Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Programas y Aplicaciones Nuevo tema Publicar Respuesta
 yum install php
Tema anterior Tema siguiente
   
juanlop89
Publicado en 22/08/14 05:36 (Leído 2386 veces)  

Nuevo
Forum User

Inscrito: 22/08/14 Publicaciones: 2
Buen día,

Necesito ayuda con un problema que tengo al tratar de actualizar php en Centos 6.5, quiero actualizarlo a la versión 5.4 ya que así me lo requiere Moodle 2.7, este es el erro que me sale:

[root@moodle ~]# yum install php
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again


en espera de su ayuda,

saludos,
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 23/08/14 02:02  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1725
País:Mexico
Tienes mal configurado el almacén YUM de EPEL. Por favor revisa el archivo correspondiente en /etc/yum.repos.d/.

Sugiero mejor instales CentOS 7. Ese trae PHP 5.4 sin añadir más.
 
Perfil Sitio Web
 Citar
juanlop89
Publicado en 25/08/14 02:45  

Nuevo
Forum User

Inscrito: 22/08/14 Publicaciones: 2
Buen día, ya pude pasar de ese error, segun los pasos que me dieron para instalar Moodle ya los realicé, pero me genera el siguiente error al intentar ingresar por el explorador: Error: database driver problem detected The site administrator should verify server configuration PHP has not been properly configured with the MySQLi extension so that it can communicate with MySQL. Please check your php.ini file or recompile PHP. MySQLi extension is not available for PHP 4.
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 28/08/14 07:59  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1725
País:Mexico
El error indica que no tienes instalado el soporte para MySQL para esa versión de PHP.

PHP Formatted Code
yum -y install php-mysql && service httpd restart


O bien:

PHP Formatted Code
yum -y install php54-mysql && service httpd restart


Nuevamente: Sugiero mejor instales CentOS 7. Usa PHP 5.4 de modo predeterminado.
 
Perfil Sitio Web
 Citar
Contenido generado en: 0,27 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 03:16 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado