Cómo instalar Java 1.5 en CentOS 5

Autor: Joel Barrios Dueñas
Correo electrónico: darkshram en gmail punto com
Sitio de Red: http://www.alcancelibre.org/
Jabber ID: darkshram@jabber.org

Creative Commons Reconocimiento-NoComercial-CompartirIgual 2.1

© 1999-2008 Joel Barrios Dueñas. Usted es libre de copiar, distribuir y comunicar públicamente la obra y hacer obras derivadas bajo las condiciones siguientes: a) Debe reconocer y citar al autor original. b) No puede utilizar esta obra para fines comerciales (incluyendo su publicación, a través de cualquier medio, por entidades con fines de lucro). c) Si altera o transforma esta obra o genera una obra derivada, sólo puede distribuir la obra generada bajo una licencia idéntica a ésta. Al reutilizar o distribuir la obra, tiene que dejar bien claro los términos de la licencia de esta obra. Alguna de estas condiciones puede no aplicarse si se obtiene el permiso del titular de los derechos de autor. Los derechos derivados de usos legítimos u otras limitaciones no se ven afectados por lo anterior. Licencia completa en castellano. La información contenida en este documento y los derivados de éste se proporcionan tal cual son y los autores no asumirán responsabilidad alguna si el usuario o lector hace mal uso de éstos.

Introducción.

De modo predeterminado, CentOS 5 y Red Hat™ Enterprise Linux 5 incluyen la versión 1.4.2 de Java por GNU.org. Sin embargo, algunos desarrollos, sobre todo aplicaciones comerciales para Apache Tomcat, pueden requerir utilizar una versión distinta de Java. Este documento explica como instalar JDK 1.5.0 de Sun Microsystems en CentOS 5 y Red Hat™ Enterprise Linux 5.

Instalación del equipamiento lógico necesario.

Instalación a través de yum.

Si utiliza CentOS 5, Red Hat™ Enterprise Linux 5 o White Box Enterprise Linux 5, solo se necesita realizar lo siguiente para instalar o actualizar el equipamiento lógico necesario:

yum -y install rpm-build gcc gcc-c++ redhat-rpm-config automake autoconf

Procedimientos.

Creación de usuario para utilizar rpmbuild.

Es poco conveniente y representa un alto riego utilizar rpmbuild como root. Por lo tanto es recomendable crear una cuenta de usuario destinada exclusivamente a utilizar el mandato rpmbuild.

su - root
useradd rpmbuilduser
passwd rpmbuilduser

Creación de estructura de directorios para rpmbuild.

A fin de poder trabajar cómodamente, se creará como usuario un conjuto de directorios que serán utilizados para crear paquetería RPM.

su - rpmbuilduser
mkdir -p ~/rpmbuild/{SOURCES,SRPMS,SPECS,RPMS,TMP,BUILD}

Utilizando vi o cualquier otro editor detexto, configure el archivo ~/.rpmmacros con el siguiente contenido:

%_topdir /home/rpmbuilduser/rpmbuild
%_tmppath %{_topdir}/TMP
%_unpackaged_files_terminate_build 0
%packager               Mi nombre 
%distribution           Mi distribución o área de trabajo.
%vendor                 Mi empresa.

Descargar el archivo java-1.5.0-sun-1.5.0.15-1jpp.nosrc.rpm o bien una versión posterior a la edición de este documento, localizado en http://mirrors.dotsrc.org/jpackage/5.0/generic/non-free/SRPMS/.

A continuación, se debe descargar la más reciente versión de JDK de Sun Microsystems desde http://java.sun.com/products/archive/

Hacer ejecutable el archivo descargado utilizando el siguiente mandato:

chmod +x jdk-1_5_0_15-linux-i586.bin

Mover éste último dentro de ~/rpmbuild/SOURCES/

mv jdk-1_5_0_15-linux-i586.bin ~/rpmbuild/SOURCES/

Reconstruir el paquete java-1.5.0-sun-1.5.0.15-1jpp.nosrc.rpm para generar los paquetges de Java 1.5.

rpmbuild --rebuild java-1.5.0-sun-1.5.0.15-1jpp.nosrc.rpm

Lo anterior, luego de algunos minutos, generará dentro del directorio ~/rpmbuild/RPMS/i586/ los siguientes paquetes:

Para instalar, cambiarse al directorio ~/rpmbuild/RPMS/i586/ e instalar solo la paquetería requerida. Ejemplo:

cd ~/rpmbuild/RPMS/i586/
su
rpm -Uvh java-1.5.0-sun-1.5.0.15-1jpp.i586.rpm java-1.5.0-sun-alsa-1.5.0.15-1jpp.i586.rpm java-1.5.0-sun-fonts-1.5.0.15-1jpp.i586.rpm java-1.5.0-sun-plugin-1.5.0.15-1jpp.i586.rpm
exit

De modo predeterminado, el sistema utiliza la versión 1.4.2 de GNU.org.Se puede definir desde la terminal que versión de Java utilizar a través delmandato alternatives con la opción --config java.

/usr/sbin/alternatives --config java

Lo anterior devuelve una salida similar a la siguiente:

Hay 2 programas que proporcionan 'java'.

  Selección    Comando
-----------------------------------------------
*+ 1           /usr/lib/jvm/jre-1.4.2-gcj/bin/java
   2           /usr/lib/jvm/jre-1.5.0-sun/bin/java

Presione Intro para mantener la selección actual[+] o escriba el
número de la selección:  

Seleccione la versión 1.5 de de Sun Microsystems pulsando la tecla del número 2 y luego la tecla ENTER.

Para verificar que la versión de Java 1.5 ha sido instalada correctamente, solo basta ejecutar el siguiente mandato:

java -version

Para finalizar, si el sistema dispone de Mozilla Firefox, se puede configurar el complemento Java (Plugin Java) creando un enlace simbólico de /usr/lib/jvm/jre-1.5.0-sun/plugin/i386/ns7/libjavaplugin_oji.so dentro de /usr/lib/mozilla/plugins/ de la siguiente manera:

ln -s /usr/lib/jvm/jre-1.5.0-sun/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla/plugins/