Cursos Servidores con Centos
Sistema Operativo ALDOS

Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Redes y Servidores Nuevo tema Publicar Respuesta
 Disco duro no funciona luego de ejecutar comando Lilo
Tema anterior Tema siguiente
   
jpi90
Publicado en 14/08/21 10:51 (Leído 1387 veces)  

Nuevo
Forum User

Inscrito: 14/08/21 Publicaciones: 1
Buenas!

Tengo un problema con mi disco duro. Tengo dos discos duros diferentes, uno con Windows y otro con Linux.

El problema fue que, después de instalar el disco duro de Linux, cometí un error e instalé GRUB en el disco duro de Windows.

Desde entonces, el disco duro de Windows comenzó a funcionar realmente mal, a veces ni siquiera podía arrancar desde allí. Pero hasta ese momento todavía funcionaba.

Tratando de arreglar esto, encontré a un tipo que sugirió hacer "lilo -M / mbr / dev / sda" (sda era el disco duro de Windows). Así que lo intenté. Desde que hice eso, mi disco duro ya no es reconocido por Linux.

¡¡Ni siquiera puedo leer mis datos para guardarlos !!

¿Alguien me puede ayudar con esto? ¿Cómo puedo hacer que el disco duro vuelva a funcionar?

Muchas gracias.
Saludos,

Juan
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 26/08/21 10:13  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1761
País:Mexico
Lilo era el gestor de arranque de Linux el siglo pasado, literalmente. No se usa desde hace más de 20 años, salvo en distribuciones Linux muy viejas específicas para equipos de legado. 99% de las distribuciones ni siquiera lo incluye. Era probablemente la peor opción de todas para hacer lo que necesitabas. Pudiste simplemente haber iniciado en Windows y seguir procedimientos específicos. Salvo que tengas un Windows 95/98/Me que arrancaban con MS-DOS, los Windows modernos no son compatibles con lo que hace Lilo.

El MBR consiste en los primeros 512 bytes del disco duro o unidad de almacenamiento utilizado para el sistema operativo, donde:

- Los primeros 446 bytes corresponden al gestor de arranque
- Los siguientes 64 bytes corresponden a la tabla de particiones. 16 bytes para cada partición primaria y/o extendida que existan.
- Los últimos 2 bytes corresponden a la firma de unidad con capacidad de inicio. También se les conoce como los 2 bytes mágicos.

Por lo que describes, lo que ejecutaste obviamente salió mal. Salvo que previamente hayas hecho un respaldo de la tabla de particiones, se ve complicado que como novato puedas recuperarla (tendrías que adivinar exactamente en que sector inicia y en cual termina cada partición y recrear la tabla de partciones). Puedes intentar llevar el disco a una empresa de recuperación de datos, pero regularmente cobran una barbaridad.

Puedes intentar iniciar en Linux (si aún puedes hacerlo) y ejecutar como root:

BASH Formatted Code
fdisk -l /dev/sda


Lo anterior debe mostrar la tabla de particiones de /dev/sda, con lo cual puedes validar si aún hay una tabla de particiones que rescatar.

Ejecutando:

BASH Formatted Code
fdisk /dev/sda


Puedes entrar al modo de edición de fdisk e intentar corregir las banderas o tipos de particiones que estén mal.

O bien puedes intentar volver a instalar grub2:

BASH Formatted Code
grub2-install /dev/sda


E iniciar en Windows y usar procedimientos específicos para Windows.
 
Perfil Sitio Web
 Citar
Contenido generado en: 0,09 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 07:08 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado