Cursos Servidores con Centos
Sistema Operativo ALDOS

Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Soporte técnico de ALDOS Nuevo tema Publicar Respuesta
 Sarg 2.3.1 en Centos
Tema anterior Tema siguiente
   
al-serv
Publicado en 24/01/14 10:51 (Leído 3342 veces)  

Miembro Activo
Forum User

Inscrito: 01/03/08 Publicaciones: 641
País:Cataluña
Hola!

estoy intentando montar sarg y la única versión que he conseguido que funcione es la que tenéis en vuestro repo para el6 y tenéis la versión 2.2.5-3, habría posibilidad de que subáis la versión a ver si con vuestros rpm me funciona ya que he probado varios y todos dan error

Unos por la ruta que buscan el sarg.conf en /etc/sarg.conf ( ni que lo copie alli da varios errores más

Otros es que no encuentran la fuente DejaVuSans.ttf en la ruta /usr.....

Vaya que no hay manera de que funcione, al generar el informe con sarg siempre da errores! he intentado compilar varios pero no van y el que tenéis vosotros si

Espero vuestra respuesta!
 
Perfil Sitio Web
 Citar
Nik0
Publicado en 24/01/14 12:28  

Participa mucho
Forum User

Inscrito: 20/08/13 Publicaciones: 60
Si pudieras reportar un log o mostrar en patalla el resultado del error al instalar o bien ejecutar Sarg podríamos ayudarte, no somos adivinos.

Por otra parte, es muy raro que te de error al compilar, yo lo he compilado a mano y después de instalar las dependencias necesarias (todas las aplicaciones para linux que las pretendas compilar traen un archivo README donde explica los requerimientos y necesidades) no da problemas. De hecho me parece que en RPM-FORGE esta el rpm sin necesidad de compilarlo.

Pero, como te mencione al principio, deberías explicarnos bien tu escenario, desde la distribución o versión de centos que usas hasta los errores que te da.
 
Perfil
 Citar
al-serv
Publicado en 24/01/14 04:13  

Miembro Activo
Forum User

Inscrito: 01/03/08 Publicaciones: 641
País:Cataluña
madre miá, perdón por existir! ;(

bueno te pongo lo que me pides:

Distro CentOS 6.5

Los paquetes de rpmfusion son los que me dan el error, es la versión 2.3.1-1

El error no es al compilar, es cuando lo instalas que se instala bien pero cuando le das a que te genere los repos da el error de que no encuentra el archivo /usr/share/fonts/truetype/ttf-dejavu/DejaSans.ttf

Alguna información te hace falta?? Sonrisa
 
Perfil Sitio Web
 Citar
Nik0
Publicado en 03/02/14 12:54  

Participa mucho
Forum User

Inscrito: 20/08/13 Publicaciones: 60
Creo que la ironía no es necesaria.

Por otro lado, estas trabajando con una versión que fue liberada hace mas de 5 años y si no existe un RPM mas actualizado tendrás que compilarlo a mano instalando las dependencias necesarias que indica el archivo README. Me imagino que el error que te da en pantalla es por que no encuentra una fuente apropiada (Dejavu) para generar un informe. Muy probablemente por que en Centos 6 este en otra ubicación a diferencia de Centos 5.

Instala primero las herramientas de desarrollo

PHP Formatted Code
yum groupinstall "Herramientas de Desarrollo" -y


baja una versión mas reciente de Sarg

PHP Formatted Code
wget http://sourceforge.net/projects/sarg/files/sarg/sarg-2.3.7/sarg-2.3.7.tar.gz/download


luego de descomprimir y direccionarte a la carpeta donde quedo el programa

PHP Formatted Code
./configure && make && make install


Y luego prueba...
 
Perfil
 Citar
al-serv
Publicado en 03/02/14 06:04  

Miembro Activo
Forum User

Inscrito: 01/03/08 Publicaciones: 641
País:Cataluña
Hola!

al final he compilado el paquete RPM corrigiendo las rutas y me esta funcionando correctamente!

Gracias por tu respuesta!
 
Perfil Sitio Web
 Citar
Contenido generado en: 0,74 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 05:18 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado