Cursos Servidores con Centos
Sistema Operativo ALDOS

Si algunos de nuestros foros, manuales, ALDOS, paquetería o proyectos te han resultado de ayuda, apreciaremos mucho nos apoyes con un donativo.

 Índice > Todo acerca de Linux > Soporte técnico de ALDOS Nuevo tema Publicar Respuesta
 Gambas
Tema anterior Tema siguiente
   
vhglezc
Publicado en 26/07/14 03:05 (Leído 2631 veces)  

Nuevo
Forum User

Inscrito: 26/07/14 Publicaciones: 8
Hola buenos días, antes que nada les mando una felicitación por este excelente proyecto, sigan adelante como hasta ahora.. Big Grin

El motivo de mi mensaje es por lo siguiente estoy intentando instalar Gambas pero me esta generando el siguiente error:

yum install gambas-ide

Complementos cargados:merge-conf, refresh-packagekit
Resolviendo dependencias
--> Ejecutando prueba de transacción
---> Paquete gambas-ide.i686 0:1.0.19-13.fc14 debe ser instalado
--> Procesando dependencias: gambas-gb-net-curl = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-qt-kde-html = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-db = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-qt-editor = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-xml-libxml-xslt = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-compress = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-net = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-runtime = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-xml-libxml = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-xml-libxml-rpc = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-qt = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-sdl = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-vb = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-qt-kde = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-qt-ext = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-eval = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: gambas-gb-debug = 1.0.19-13.fc14 para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Procesando dependencias: /usr/bin/gbx para el paquete: gambas-ide-1.0.19-13.fc14.i686
--> Ejecutando prueba de transacción
---> Paquete gambas-gb-compress.i686 0:1.0.19-13.fc14 debe ser instalado
---> Paquete gambas-gb-db.i686 0:1.0.19-13.fc14 debe ser instalado
--> Procesando dependencias: libmysqlclient.so.16 para el paquete: gambas-gb-db-1.0.19-13.fc14.i686
El paquete mysql-libs se hace obsoleto con mariadb-libs, pero el paquete que lo hace obsoleto no ofrece requerimientos
--> Procesando dependencias: libpq.so.5 para el paquete: gambas-gb-db-1.0.19-13.fc14.i686
--> Procesando dependencias: libmysqlclient.so.16(libmysqlclient_16) para el paquete: gambas-gb-db-1.0.19-13.fc14.i686
El paquete mysql-libs se hace obsoleto con mariadb-libs, pero el paquete que lo hace obsoleto no ofrece requerimientos
---> Paquete gambas-gb-debug.i686 0:1.0.19-13.fc14 debe ser instalado
---> Paquete gambas-gb-eval.i686 0:1.0.19-13.fc14 debe ser instalado
---> Paquete gambas-gb-net.i686 0:1.0.19-13.fc14 debe ser instalado
---> Paquete gambas-gb-net-curl.i686 0:1.0.19-13.fc14 debe ser instalado
---> Paquete gambas-gb-qt.i686 0:1.0.19-13.fc14 debe ser instalado
--> Procesando dependencias: libqt-mt.so.3 para el paquete: gambas-gb-qt-1.0.19-13.fc14.i686
---> Paquete gambas-gb-qt-editor.i686 0:1.0.19-13.fc14 debe ser instalado
---> Paquete gambas-gb-qt-ext.i686 0:1.0.19-13.fc14 debe ser instalado
---> Paquete gambas-gb-qt-kde.i686 0:1.0.19-13.fc14 debe ser instalado
--> Procesando dependencias: libkdeui.so.4 para el paquete: gambas-gb-qt-kde-1.0.19-13.fc14.i686
--> Procesando dependencias: libkdecore.so.4 para el paquete: gambas-gb-qt-kde-1.0.19-13.fc14.i686
--> Procesando dependencias: libkio.so.4 para el paquete: gambas-gb-qt-kde-1.0.19-13.fc14.i686
--> Procesando dependencias: libDCOP.so.4 para el paquete: gambas-gb-qt-kde-1.0.19-13.fc14.i686
---> Paquete gambas-gb-qt-kde-html.i686 0:1.0.19-13.fc14 debe ser instalado
---> Paquete gambas-gb-sdl.i686 0:1.0.19-13.fc14 debe ser instalado
--> Procesando dependencias: libSDL_mixer-1.2.so.0 para el paquete: gambas-gb-sdl-1.0.19-13.fc14.i686
---> Paquete gambas-gb-vb.i686 0:1.0.19-13.fc14 debe ser instalado
---> Paquete gambas-gb-xml-libxml.i686 0:1.0.19-13.fc14 debe ser instalado
---> Paquete gambas-gb-xml-libxml-rpc.i686 0:1.0.19-13.fc14 debe ser instalado
---> Paquete gambas-gb-xml-libxml-xslt.i686 0:1.0.19-13.fc14 debe ser instalado
---> Paquete gambas-runtime.i686 0:1.0.19-13.fc14 debe ser instalado
--> Procesando dependencias: libgettextlib-0.18.1.so para el paquete: gambas-runtime-1.0.19-13.fc14.i686
--> Ejecutando prueba de transacción
---> Paquete SDL_mixer.i686 0:1.2.12-3.fc14.al debe ser instalado
--> Procesando dependencias: libmikmod para el paquete: SDL_mixer-1.2.12-3.fc14.al.i686
---> Paquete gambas-gb-db.i686 0:1.0.19-13.fc14 debe ser instalado
--> Procesando dependencias: libmysqlclient.so.16 para el paquete: gambas-gb-db-1.0.19-13.fc14.i686
El paquete mysql-libs se hace obsoleto con mariadb-libs, pero el paquete que lo hace obsoleto no ofrece requerimientos
--> Procesando dependencias: libmysqlclient.so.16(libmysqlclient_16) para el paquete: gambas-gb-db-1.0.19-13.fc14.i686
El paquete mysql-libs se hace obsoleto con mariadb-libs, pero el paquete que lo hace obsoleto no ofrece requerimientos
---> Paquete gettext-libs.i686 0:0.18.1.1-5.fc14 debe ser instalado
---> Paquete kdelibs3.i686 0:3.5.10-54.fc14.al debe ser instalado
--> Procesando dependencias: kde-settings >= 3.5 para el paquete: kdelibs3-3.5.10-54.fc14.al.i686
--> Procesando dependencias: kdelibs-common para el paquete: kdelibs3-3.5.10-54.fc14.al.i686
--> Procesando dependencias: libartsflow.so.1 para el paquete: kdelibs3-3.5.10-54.fc14.al.i686
--> Procesando dependencias: libartsflow_idl.so.1 para el paquete: kdelibs3-3.5.10-54.fc14.al.i686
--> Procesando dependencias: libkmedia2_idl.so.1 para el paquete: kdelibs3-3.5.10-54.fc14.al.i686
--> Procesando dependencias: libmcop.so.1 para el paquete: kdelibs3-3.5.10-54.fc14.al.i686
--> Procesando dependencias: libqtmcop.so.1 para el paquete: kdelibs3-3.5.10-54.fc14.al.i686
--> Procesando dependencias: libsoundserver_idl.so.1 para el paquete: kdelibs3-3.5.10-54.fc14.al.i686
---> Paquete postgresql-libs.i686 0:9.0.16-1.fc14.al debe ser instalado
---> Paquete qt3.i686 0:3.3.8b-58.fc14.al debe ser instalado
--> Ejecutando prueba de transacción
---> Paquete arts.i686 8:1.5.10-13.fc14.al debe ser instalado
--> Procesando dependencias: libaudiofile.so.0 para el paquete: 8:arts-1.5.10-13.fc14.al.i686
--> Procesando dependencias: libesd.so.0 para el paquete: 8:arts-1.5.10-13.fc14.al.i686
---> Paquete gambas-gb-db.i686 0:1.0.19-13.fc14 debe ser instalado
--> Procesando dependencias: libmysqlclient.so.16 para el paquete: gambas-gb-db-1.0.19-13.fc14.i686
El paquete mysql-libs se hace obsoleto con mariadb-libs, pero el paquete que lo hace obsoleto no ofrece requerimientos
--> Procesando dependencias: libmysqlclient.so.16(libmysqlclient_16) para el paquete: gambas-gb-db-1.0.19-13.fc14.i686
El paquete mysql-libs se hace obsoleto con mariadb-libs, pero el paquete que lo hace obsoleto no ofrece requerimientos
---> Paquete kde-settings.noarch 0:4.5-11.fc14 debe ser instalado
---> Paquete kdelibs-common.i686 6:4.6.5-8.fc14 debe ser instalado
---> Paquete libmikmod.i686 0:3.3.6-1.fc14.al debe ser instalado
--> Ejecutando prueba de transacción
---> Paquete audiofile.i686 1:0.2.7-2.fc14.al debe ser instalado
---> Paquete esound-libs.i686 1:0.2.41-4.fc14.al debe ser instalado
---> Paquete gambas-gb-db.i686 0:1.0.19-13.fc14 debe ser instalado
--> Procesando dependencias: libmysqlclient.so.16 para el paquete: gambas-gb-db-1.0.19-13.fc14.i686
El paquete mysql-libs se hace obsoleto con mariadb-libs, pero el paquete que lo hace obsoleto no ofrece requerimientos
--> Procesando dependencias: libmysqlclient.so.16(libmysqlclient_16) para el paquete: gambas-gb-db-1.0.19-13.fc14.i686
El paquete mysql-libs se hace obsoleto con mariadb-libs, pero el paquete que lo hace obsoleto no ofrece requerimientos
--> Resolución de dependencias finalizada
Error: Paquete: gambas-gb-db-1.0.19-13.fc14.i686 (fedora)
Necesita: libmysqlclient.so.16(libmysqlclient_16)
Disponible: mysql-libs-5.1.51-2.fc14.i686 (fedora)
libmysqlclient.so.16(libmysqlclient_16)
Disponible: mysql-libs-5.1.60-1.fc14.i686 (updates)
libmysqlclient.so.16(libmysqlclient_16)
Disponible: mysql-libs-5.5.32-1.fc14.al.i686 (ALDOS)
~libmysqlclient.so.18(libmysqlclient_16)
~libmysqlclient.so.18(libmysqlclient_18)
Error: Paquete: gambas-gb-db-1.0.19-13.fc14.i686 (fedora)
Necesita: libmysqlclient.so.16
Disponible: mysql-libs-5.1.51-2.fc14.i686 (fedora)
libmysqlclient.so.16
Disponible: mysql-libs-5.1.60-1.fc14.i686 (updates)
libmysqlclient.so.16
Disponible: mysql-libs-5.5.32-1.fc14.al.i686 (ALDOS)
~libmysqlclient.so.18
Podría intentar utilizar el comando --skip-broken para sortear el problema
Podría intentar ejecutar: rpm- Va --nofiles --nodigest

Cual es el error porque por lo que veo menciona la incompabilidad de mariaDB con MySql..

Agradezco su ayuda de antemano...
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 26/07/14 04:25  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1761
País:Mexico
Efectivamente. Es un conflicto entre MySQL y MariaDB, pero es porque estás intentando instalar una versión vieja/obsoleta de gambas (2.x) que aún está disponible en los almacenes YUM de legado de Fedora.

Intenta con:

PHP Formatted Code
yum -y install gambas3


La versión 3.4.2 instalará sin mayor problema.

 
Perfil Sitio Web
 Citar
vhglezc
Publicado en 27/07/14 02:26  

Nuevo
happy
Forum User

Inscrito: 26/07/14 Publicaciones: 8
Gracias por la respuesta tan pronta, efectivamente toda se ha instalado sin ningún problema, en hora buena por este gran proyecto... Gracias Joel Sigue adelante..
 
Perfil
 Citar
vhglezc
Publicado en 27/07/14 02:56  

Nuevo
gloomy
Forum User

Inscrito: 26/07/14 Publicaciones: 8
Vuelvo a molestar ya pude llevar a cabo la instalación de gambas3 sin problema pero ahora no logra ejecutar el programa.. lo intente abrir por comando y me manda el siguiente error:

gbr3: unable to load component: gb.form.stock

Ya he actualizado el sistema para ver si había algún cambio y nada... Que podrá ser..??
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 29/07/14 12:55  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1761
País:Mexico
¿Está instalado gambas3-gb-form-stock? Es una dependencia no documentada de los paquetes de Fedora sobre los cuales baso los de ALDOS.

PHP Formatted Code
rpm -q gambas3-gb-form-stock || yum install gambas3-gb-form-stock


 
Perfil Sitio Web
 Citar
vhglezc
Publicado en 29/07/14 03:09  

Nuevo
working
Forum User

Inscrito: 26/07/14 Publicaciones: 8
Gracias Joel ha quedado resuelto el problema con la instrucción que diste, ahora tengo otro problema Rolling Eyes en instalado también el IDE Anjuta.. y al ejecutarlo me marca este error..

libanjuta-symbol-db:ERROR:symbol-db-query.c:863:sdb_query_set_property: assertion failed: (priv->dbe_project != NULL)

Pensé en buscar un paquete perdido como sucedió con gambas pero no hay nada que instalar buscando el error me encontré con esta pagina

https://groups.google.com/forum/#!topic/bugzillagnometelconnect4688-bugzillagnometelconnect4688/Qu3DqN988q0

pero ahí mencionan que es con otra versión del programa... sera por conflicto de versiones..???

Gracias de antemano...
 
Perfil
 Citar
Joel Barrios Dueñas
Publicado en 29/07/14 06:41  

Admin
Site Admin

Inscrito: 17/02/07 Publicaciones: 1761
País:Mexico
Para anjuta dame un par de días. Tengo que recompilar algunas bibliotecas compartidas.
 
Perfil Sitio Web
 Citar
vhglezc
Publicado en 31/07/14 03:57  

Nuevo
Forum User

Inscrito: 26/07/14 Publicaciones: 8
Ok agradezco tu tiempo y dedicación animo con este proyecto... Big Grin
 
Perfil
 Citar
jeduardomoreno
Publicado en 31/07/14 04:10  

Nuevo
Forum User

Inscrito: 31/07/14 Publicaciones: 1
Aunque no es software libre, te voy a recomendar que le des una vista a Xojo (xojo.com). Tiene la particularidad de que lo que desde un mismo código fuente, puedes generar ejecutables para Windows, Linux y Mac.
Es BASIC, así que si vas a trabajar con GAMBAS es que conoces BASIC.
No es muy oneroso y aunque se llegan a requerir plug-ins de terceros, no son muy caros.
Te lo comento porque GAMBAS no genera ejecutables para otras plataformas, y aunque no lo he probado en ALDOS, tengo conocidos que lo han hecho en Ubuntu y han detectado errores.
 
Perfil
 Citar
vhglezc
Publicado en 01/08/14 09:48  

Nuevo
Forum User

Inscrito: 26/07/14 Publicaciones: 8
Buenas tardes reporto un error nuevo ahora en otra aplicación (dia) al ejecutar esta es la salida del comando...

(dia:4911): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(dia:4911): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(dia:4911): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(dia:4911): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised

(dia:4911): GLib-WARNING **: A group named "gtk" is already part of this GOptionContext

(dia:4911): GLib-GObject-WARNING **: attempting to add an interface (DiaInteractiveRendererInterface) to class (DiaGdkRenderer) after class_init

** (dia:4911): CRITICAL **: dia_renderer_set_size: assertion 'irenderer != NULL' failed

** (dia:4911): CRITICAL **: dia_renderer_set_size: assertion 'irenderer != NULL' failed
Violación de segmento

Agradezco tu sugerencia de Xojo lo tomare en cuenta...


 
Perfil
 Citar
Contenido generado en: 0,32 segundos Nuevo tema Publicar Respuesta
 Todas las horas son UTC. Hora actual 03:49 .
Tema normal Tema normal
Tema persistente Tema persistente
Tema cerrado Tema cerrado
Nueva publicación Nueva publicación
Persistente con nueva publicación Persistente con nueva publicación
Cerrado con nueva publicación Cerrado con nueva publicación
Ver publicaciones anónimas 
Usuarios anónimos pueden publicar 
Se permite HTML Filtrado 
Contenido censurado